1291The Party's in Dolores's Driveway

The Party's in Dolores's Driveway

Time Limit: 1 Seconds     Memory Limit: 32768 K

Total Submit:221     Accepted:87


Description

Dolores's house has an unusual semi-circular driveway that can accommodate 26 cars in a single file, with exits at the front and the back. This is nice because when she hosts a party because everyone can park in the driveway. However, it causes complications when a guest wants to leave, because other guests with cars blocking that person must move their cars temporarily. Her guests take this in stride, and make a game out of the nuisance. When someone leaves, those cars that must move return to the driveway in reverse order. Since there are two ways for the leaving car to exit (through the front or rear exit), the cars on the shorter path to an exit must move (and return in reverse order). If the car that wants to leave is exactly in the middle, the front cars (on the left) must move. For example, suppose the initial driveway configuration is represented as ABCDEFG. Suppose further that the owner of car E decides to leave. Then the owners of cars F and G must move (since they’re on the shorter path to an exit) to make room for E to leave, and then return to the driveway in reverse order. The new driveway configuration will be ABCDGF. Suppose now C wants to leave. Here, A and B have to move (since they’re on the shorter path to an exit) , with the resulting configuration BADGF. Let’s say that now D wants to leave. In this case, B and A must move (since both exit paths are of equal length, and A and B are on the path to the front exit). The resulting configuration is ABGF. Write a program to simulate this party game.

Input

Each data set begins with a line containing only a string of uppercase letters, representing the initial order of cars in the driveway as described above. The string will contain at least one letter, and no letter is duplicated. The next line contains an integer n>=0. The next n lines each contain only a single uppercase letter, indicating the next car to leave the party; this letter is guaranteed to represent one of the remaining cars at the party. Your program should stop processing data sets when it reaches an initial driveway order of STOP.

Output

Begin the output for each data set by indicating the data set number and the initial order of cars in the driveway. As each car leaves, output the new car order. Follow the output format indicated in the Sample Output. Leave a blank line between the output for different data sets.

Sample Input

ABCDEFG
3
E
C
D
HIWORLD
1
H
STOP

 

Sample Output

Dataset #1:  The initial order is ABCDEFG.
After E leaves, the order is ABCDGF.
After C leaves, the order is BADGF.
After D leaves, the order is ABGF.

Dataset #2:  The initial order is HIWORLD.
After H leaves, the order is IWORLD.

 

Source

2000 ACM Southeast Regional

 

Source:

#include<iostream>
using namespace std;
int main()
{
	char a[30],w,t;int n,i,j,m,k,l;l=1;
	while(cin>>a)
	{
		int b[27]={0};
		if(strcmp(a,"STOP")==0)
			break;
		printf("Dataset #%d:  The initial order is %s./n",l,a);
		l++;
         cin>>n;
		 m=strlen(a);
		 while(n--)
		 {
			 cin>>w;
			 i=0;
			 while(a[i]!='/0')
			 {
				 if(a[i]==w)
					 break;
				 i++;
			 }
			 j=i;
			 if(i+1>(m+1)/2)
			 {
				 k=m-1;
				 a[i]=a[k];
				 i++;
				 k--;
				 while(k>i)
				 {
					 t=a[i];
					 a[i]=a[k];
					 a[k]=t;
					 i++;
					 k--;
				 }
				 a[m-1]='/0';
			 }
			 else
			 {
				 while(a[i]!='/0')
				 {
					 a[i]=a[i+1];
					 i++;
				 }
				 k=0;
				 j--;
				 while(j>k)
				 {
					 t=a[j];
					 a[j]=a[k];
					 a[k]=t;
					 j--;
					 k++;
				 }
			 }
			 m--;
			 printf("After %c leaves, the order is %s./n",w,a);
		 }
		 printf("/n");
	}
	return 0;
}

 

 

用土办法了,呵呵,没有科技含量,不懂哪位能指点一下下

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过信息化手段提升教育、管理和服务水平,实现资源数字化、工作流程化、管理高效化和决策智能化。方案包括智慧校园信息化平台和安防平台的建设,涉及教学、科研、管理和服务等多个方面,以满足现代教育和培训需求。 技术服务要求强调了统一支撑平台的建设,包括数据标准、接口标准、代码标准和用户信息标准的统一制定。平台需满足信创和X86交叉适配要求,确保安全自主可控的系统开发环境。此外,方案还涵盖了用户中心系统、统一认证授权中心、统一工作流中心、统一智能报表中心等多个模块,以及数据共享中心、语音识别、移动服务终端等功能,以实现校园内外部信息的互联互通和资源共享。 智慧校园信息化平台的建设还包括了对教学管理、人事管理、公文管理、档案管理、即时通讯、会议管理、督办工作、资产管理等方面的数字化和自动化升级。这些模块的集成旨在提高工作效率,优化资源配置,加强监督管理,并通过移动应用等技术手段,实现随时随地的信息访问和业务处理。 安防平台的建设则侧重于校园安全,包括停车场管理、人脸识别测温、访客自助登记、视频监控等多个系统。这些系统的集成旨在提高校园的安全管理水平,实现对校园内外人员和车辆的有效监控和管理,确保校园环境的安全稳定。 最后,方案还提到了对固定资产的管理,包括购置、使用、归还、报废等全生命周期的管理,以及对网络设备、安防设备、服务器等硬件设施的配置和管理。通过这些措施,智慧校园建设方案旨在为校园提供一个安全、高效、便捷的学习和工作环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值