Problem C: Say Hello Today

Problem C: Say Hello Today

Time Limit: 1 Sec   Memory Limit: 2 MB
Submit: 985   Solved: 419
[ Submit][ Status][ Web Board]

Description

输出一句话,告诉今天的日期。

补全代码使append.cc的程序能够运行。

Input

输入三个整数,分别为年月日。

Output

输出格式见样例。

Sample Input

2013 4 3

Sample Output

Hello, today is 2013-4-3.Hello, today is 2013-4-1.Hello, today is 2013-1-1.Hello, today is 2000-1-1.

HINT

试试函数的默认形参。


Append Code

int main()
{
     int yy, mm, dd;
     cin>>yy>>mm>>dd;
     SayHello(yy, mm, dd);
     SayHello(yy, mm);
     SayHello(yy);
     SayHello();
}
 
void SayHello( int year, int month, int day)
{
     cout<< "Hello, " ;
     cout<< "today is " ;
     cout<<year;
     cout<< "-" ;
     cout<<month;
     cout<< "-" ;
     cout<<day;
     cout<< "." ;
     cout<<endl;
}

#include<bits/stdc++.h>
using namespace std;
void SayHello(int year=2000, int month=1, int day=1);
int main()
{
    int yy, mm, dd;
    cin>>yy>>mm>>dd;
    SayHello(yy, mm, dd);
    SayHello(yy, mm);
    SayHello(yy);
    SayHello();
}


void SayHello(int year, int month, int day)
{
    cout<<"Hello, ";
    cout<<"today is ";
    cout<<year;
    cout<<"-";
    cout<<month;
    cout<<"-";
    cout<<day;
    cout<<".";
    cout<<endl;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值