数据结构实验之链表七:单链表中重复元素的删除(使用C语言)
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Sample Input
10
21 30 14 55 32 63 11 30 55 30
Sample Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
Hint
Source
不得使用数组!
#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
int i,n;
struct node *head,*p;
scanf("%d",&n);
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
printf("%d\n",n);
for(p=head->next;p!=NULL;p=p->next)
{
if(p->next==NULL) printf("%d\n",p->data);
else printf("%d ",p->data);
}
struct node *q,*t;
t=(struct node *)malloc(sizeof(struct node));
t->next=NULL;
for(p=head->next;p!=NULL;p=p->next)
{
t=p;
q=p->next;
while(q)
{
if(p->data==q->data)
{
q=q->next;
t->next=q;
n--;
}
else
{
q=q->next;
t=t->next;
}
}
}
printf("%d\n",n);
for(p=head->next;p!=NULL;p=p->next)
{
if(p->next==NULL) printf("%d\n",p->data);
else printf("%d ",p->data);
}
return 0;
}