kuangbin 专题四:G题(dis数组性质) MPI Maelstrom

 

G - MPI Maelstrom

POJ1502

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output
35

题意:给你 n 个节点的拓扑图 , 然后计算从源点 1 把信号传到所有节点的最短时间 , 节点把信号传给自己用时为 0 , 并且已经被传送过信号的节点也可以向其他节点传送信号(dis伸展的过程),
  然后问题就变成了 处理 源点 1 到其他所有点的最短路问题 , 从中选出来一个 最大的 权值 就是结果 。

思路: 单源最短路, dijksual()算法处理出源点到其他点的最短路,然后从中间选出一个最大的 。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std ;

#define maxn 220
#define inf 99999999

int n ; 
char num[10] ; 
int mapp[maxn][maxn] ;
bool visit[maxn] ; 
int dis[maxn] ; 

void init() {
    for(int i=1 ; i<=n ; i++) {
        for(int j=1 ; j<= n ; j ++ ) {
            if(i == j ) mapp[i][j] = 0 ;
            else mapp[i][j] = inf ;
        }
    }
     
    for(int i=2 ; i<=n ; i++) {
        for(int j=1 ; j<i ; j++) {
            scanf("%s" , num) ;
            if(num[0] == 'x'){
                continue ; 
            }
            //atoi() 函数可以把  不同类型的数据 转换成 和mapp[i][j] 相同的类型 ,
            // 下面操作 相当于 把 char 类型的 数据转换成 int 类型的数据 
            mapp[i][j] = mapp[j][i] = atoi(num) ; 
        }
    }
}

void dijksual(int s) {
    int minn , pos , t  ;
    memset(visit , false , sizeof(visit)) ;
    visit[s] = true ;

    for(int i=1 ; i<=n ; i++) {
        dis[i] = mapp[s][i] ;
    }

    for(int i=1 ; i<=n ; i++) {
        minn = inf ;
        for(int j=1 ; j<=n ; j++) {
            if(!visit[j] && minn > dis[j]) {
                minn = dis[j] ;
                pos = j ;
            }
        }

        visit[pos] = true ;

        for(int j = 1 ; j<=n ; j++) {
            t = dis[pos] + mapp[pos][j] ;
            if(!visit[j] && dis[j] > t ) {
                dis[j] = t ;
            }
        }
    }

}

int main() {

    while(~scanf("%d" , &n)) {
        init() ; 
        
        dijksual(1) ; 
        int result = -1 ; 
        for(int i=1 ; i<= n ; i++){
            result = max(result , dis[i]) ; 
        }
        printf("%d\n" , result) ; 
    }
    return 0 ;
}
View Code

 

转载于:https://www.cnblogs.com/yi-ye-zhi-qiu/p/7786602.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值