kuangbin专题五:B - The Suspects POJ - 1611

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题意:给 n 个学生 0--n-1 顺序编号 , 然后 第 0 号 同学被认为是 传染病嫌疑者 , 之后 有 m 个团体 ,
   后面 m 行 , 每行 第一个数字 k 表示 这个团体有 k 个人 , 之后 k 个数字 表示 这个团体内同学的编号
   最后 统计 多少个人 是 传染病的怀疑者 (与第 0 号 同学 同一个集合的同学有多少位)
思路:并查集 模板题目

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std ; 

#define maxn 50000
int father[maxn] ; 
int n , m , k ;  
int num[maxn] ; 
// 初始化 编号 , 每一个元素都是一个 集合
void init(){
    for(int i=0 ; i<=n ; i++){
        father[i] = i ; 
    }
    return;
}
// 查找 x 元素 所在集合的代表元素的 编号 
// 同时 理顺 上一次 对本集合 合并 
// 导致的部分成员 没有指向代表元素 
int find(int x){
    if(x!=father[x]){
        father[x] = find(father[x]) ; 
    }
    return father[x] ; 
}
// y 所在集合 所有元素 都指向 rooty
// x 所在集合 所有元素 都指向 rootx
// 如果 x y 不是 统一集合 ,则把 y 集合的代表元素 指向 x 集合的代表元素 rootx
// 上述方法实现合并 , 会导致 一部分 y 集合元素 没有指向 rootx 
// 这种情况 会在 下一次 调用 find() 函数 时 解决
void Union_set(int x , int y){
    int rootx = find(x) ; 
    int rooty = find(y) ; 
    if(rootx!=rooty){
        father[rooty] = rootx ; 
    }
}
// 通过检查 两元素 的所在集合的代表元素 是否相等 来判断两元素是不是统一集合的元素
bool check(int x , int y){
    return find(x) == find(y) ; 
}

int main(){

    while(~scanf("%d %d" , &n , &m)){
        if(n==0&&m==0){
            break ; 
        }
        init() ; 

        for(int i=1 ; i<=m ; i++){
            scanf("%d" ,&k) ; 

            for(int j=1 ; j<=k ;  j++){
                scanf("%d" , &num[j]) ; 
            }

            for(int j=1 ; j<k ; j++){
                Union_set(num[j] , num[j+1]) ; 
            }
        }

        int result = 0 ; 
        for(int i=0 ; i<n ; i++){
            // 和 0 号 同学是 同一集合的 同学都是 嫌疑人
            if(check(i , 0 )){
                result ++ ; 
            }
        }

        printf("%d\n" , result) ; 
    }
    return 0 ; 
}
View Code

 

转载于:https://www.cnblogs.com/yi-ye-zhi-qiu/p/7998694.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值