B - The Suspects POJ - 1611(并查集)

B - The Suspects POJ - 1611(并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意:同学之间有一种传染病,在一个小组里如果有一个病人,那么全部人都有病。现在0号有病,问一共多少人有病。

思路:经典的并查集。注意在读入小组成员的时候,5 1 2 3 4 5, 表示5个人1 2 3 4 5是在一个组里,建关系的时候,直接存一下first=1,然后2 3 4 5 分别和first建立关系就好了。

代码:

#include <iostream>
#include <queue>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

using namespace std;

int pre[30005];
int n,m;

int root( int x )
{
    int i=x,j;
    while ( x!=pre[x] ) {
        x = pre[x];
    }

    while ( i!=x ) {
        j = pre[i];
        pre[i] = x;
        i = j;
    }
    return x;
}

void join( int a, int b )
{
    int x = root(a);
    int y = root(b);
    if ( x!=y ) {
        pre[max(x,y)] = min(x,y); // 大的服从小的,让0永远是大领导,方便统计有多少人是0号感染的
    }
}

int main()
{
    int i,j;
    while ( cin>>n>>m ) {
        if ( n==0 && m==0 ) {
            break ;
        }
        for ( i=0; i<n; i++ ) {
            pre[i] = i;
        }
        int first = -1;
        for ( i=0; i<m; i++ ) {
            int k;
            cin >> k;
            for ( j=0; j<k; j++ ) {
                int x;
                cin >> x;
                if ( j==0 ) {
                    first = x; // 把第一个点存起来
                    continue ;
                }
                join(first,x); // 后面的数都和第一个建立联系
            }
        }
        int ans = 0;
        for ( i=0; i<n; i++ ) {
            if ( root(i)==0 ) {  // 开始写的pre[]==0, 结果wa了
                ans ++;
            }
        }
        cout << ans << endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值