hdu 5510 KMP+暴力

12 篇文章 3 订阅
10 篇文章 0 订阅

Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6175    Accepted Submission(s): 1905


Problem Description
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.

For  n given strings  S1,S2,,Sn, labelled from  1 to  n, you should find the largest  i (1in) such that there exists an integer  j (1j<i) and  Sj is not a substring of  Si.

A substring of a string  Si is another string that occurs  in  Si. For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

Input
The first line contains an integer  t (1t50) which is the number of test cases.
For each test case, the first line is the positive integer  n (1n500) and in the following  n lines list are the strings  S1,S2,,Sn.
All strings are given in lower-case letters and strings are no longer than  2000 letters.
 

Output
For each test case, output the largest label you get. If it does not exist, output  1.
 

Sample Input
 
 
4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc
 

Sample Output
 
 
Case #1: 4 Case #2: -1 Case #3: 4

Case #4: 3

题目描述: 给你一串字符串 让你判断第几个字符串满足它前面有至少一个字符串不是它的子字符串

思路:对字符串的处理KMP很好想到 然后直接暴力会超时 所以要进行一些优化 可以在读入的时候就进行比较 如果前面是后面的子字符串

就进行标记 最后再求没有标记的

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

struct S
{
    char str[2005];
};

int f[2005];//后缀数组

void getfill(char s[])//计算后缀数组
{
    memset(f, 0, sizeof(f));
    int len = strlen(s);
    for(int i = 1;i < len;i++)
    {
        int j = f[i];
        while(j&&s[i] != s[j])
            j = f[j];
        f[i+1] = (s[i] == s[j])?j+1:0;
    }
}
//判断s是否为a的子串
int fin(char a[], char s[])
{
    getfill(s);
    int j = 0;
    int lena = strlen(a);
    int lens = strlen(s);
    for(int i = 0;i < lena;i++)
    {
        while(j&&a[i]!=s[j])
            j = f[j];
        if(a[i]==s[j])
            j++;
        if(j == lens)
            return 1;
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    S r[505];
    int v[2005];
    int m = 0;
    while(t--){
        int n;
        memset(v,1,sizeof(v));
        m++;
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%s",r[i].str);
        }
        for(int i = 1; i < n;i++)
            if(fin(r[i].str,r[i-1].str))
            v[i-1] = 0;
        int i,j;
        bool flag = false;
            for(i = n-1 ;i>=0&&!flag;i--)
            for(j=0;j<i&&!flag;j++)
                {
                if(v[j])  //优化时间
                if(!fin(r[i].str,r[j].str))
                {
                    printf("Case #%d: %d\n",m,i+1);
                    flag = true ;
                }
            }
        if(!flag)
            printf("Case #%d: -1\n",m);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值