poj 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48743 Accepted: 10884

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


Radar Installation

做的poj第一个题,题意就是在海岸上装最少的雷达(扫描半径为d)使其侦测到所有的小岛.

思路:求出小岛可以被扫描到的雷达的安装范围p[i].left,p[i].right,算完后对p排序,right大的在后面,若相同则left小的在后面。排完序后维持now_left就行了

代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
struct pp
{
    double left;
    double right;
}p[1005];
double left(int x,int y,int d)
{
    return x-sqrt(d*d-y*y);
}
double right(int x,int y,int d)
{
    return x+sqrt(d*d-y*y);
}
bool cmp(pp p1,pp p2)
{
    if(p1.right<p2.right)
    {
        return 1;
    }
    else
    {
        if(p1.right==p2.right)
            return p1.left>p2.left;
    }
    return 0;
}
int main()
{
    int n,d,Case=1;;
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(!n&&!d)break;
        int i,ok=1;;
        for(i=0;i<n;i++)
        {
            int x,y;
            //cout<<"input"<<endl;
            scanf("%d%d",&x,&y);
            if(y>d)
                ok=0;
            if(ok)
            {
                p[i].left=left(x,y,d);
                p[i].right=right(x,y,d);
            }
        }
        //cout<<"ok"<<endl;
        if(!ok)
        {
            printf("Case %d: -1\n",Case++);
            continue;
        }
        sort(p,p+n,cmp);
        int count=1;
        double now_left=p[n-1].left;
        for(i=n-2;i>=0;i--)
        {
            if(p[i].right<now_left)//这个小岛不能被已安装的雷达扫到
            {
                count+=1;
                now_left=p[i].left;//更新left
            }
            else
            {
                now_left=(now_left<p[i].left?p[i].left:now_left);//更新left
            }
        }
        printf("Case %d: %d\n",Case++,count);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值