HDU 1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58270    Accepted Submission(s): 22084



Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
 
 
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
就是找一下规律,思路是这样的:
末位数      相乘后的末位数 1           1 2           4   8   6   2 3           9   7   1   3 4           6   4 5           5 6           6 7            9   3   1   7 8            4   2   6   8 9            1   9 0            0
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int T,n,sd,digit;
	scanf("%d",&T);
	while(T--)
	{
		if(scanf("%d",&n) != EOF)
		{
			sd = n%10;
			if(sd==0 || sd==1 || sd==5 || sd==6 || sd==9)
				digit = sd;
			else if(sd == 2 || sd == 8)
			{
				if(n%4 == 0)
					sd = 6;
				else
					sd = 4;
			}
			else if(sd == 3)
			{
				if(n%4 == 1)
					sd = 3;
				else
					sd = 7;
			}
			else if(sd == 4)
			{
					sd = 6;
			}
			else{
				if(n%4 == 1)
					sd = 7;
				else
					sd = 3;
			}
			printf("%d\n",sd);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值