HDU 3367 Pseudoforest (并查集)

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 956    Accepted Submission(s): 368


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0
 

Sample Output
3
5

 

/*
  很好的一道并查集
  题目要求在图中找出所有联通分量,且每个联通分量最多只有一个环。
  所以在合并集合的时候,如果这两个集合都有环则不合并,否则将无环
  的合并到有环的那个集合,如果都无环,则直接合并。再有,如果某两个
  点属于同一个集合,则判断该集合有无环,无则将这条边的权值加上,并
  将这个集合标记为有环。否则不加这条边(这里需要贪心的思想,先将所有
  边降序排序)。
  最后统计所有满足要求的集合的总和。
  
  437MS	1548K
  */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define SIZE 10005
using namespace std;

struct node
{
    int s,e,v;
}edge[SIZE*100];

struct Node
{
    int fa,sum;
    bool circle;
};

Node fat[SIZE];
bool vis[SIZE];
int n,m;

bool cmp(node a,node b)
{
    return a.v > b.v;
}

int find(int x)
{
    if(x != fat[x].fa)
        fat[x].fa = find(fat[x].fa);
    return fat[x].fa;
}

void combine(int a,int b,int vv)
{
    int tx = find(a);
    int ty = find(b);
    if(tx != ty)
    {
        if(fat[tx].circle && fat[ty].circle)
            return ;
        if(fat[tx].circle)
        {
            fat[ty].fa = tx;
            fat[tx].sum += fat[ty].sum;
            fat[tx].sum += vv;
        }
        else
        {
            fat[tx].fa = ty;
            fat[ty].sum += fat[tx].sum;
            fat[ty].sum += vv;
        }
    }
    else
    {
        if(!fat[tx].circle)
        {
            fat[tx].circle = true;
            fat[tx].sum += vv;
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(!n && !m)
            break;
        for(int i=0; i<=n; i++)
        {
            fat[i].fa = i; fat[i].sum = 0; fat[i].circle = false;
        }
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&edge[i].s,&edge[i].e,&edge[i].v);
        sort(edge,edge+m,cmp);
        for(int i=0; i<m; i++)
            combine(edge[i].s,edge[i].e,edge[i].v);
        int ans = 0;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
        {
            int t = find(i);
            if(!vis[t])
            {
                ans += fat[t].sum;
                vis[t] = true;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值