HDU 3605 Escape (二分图的多重匹配)

Escape

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2481    Accepted Submission(s): 686


Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
1 1
1
1

2 2
1 0
1 0
1 1
 

Sample Output
YES
NO

 

/*
  二分图的多重匹配
  和最大匹配类似,只不过记录连接的边时,不再是只记录
  一个,而是记录点能容纳的匹配数量。
  
  703MS	8000K
  */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define SIZE 100005

using namespace std;

int N,M,ans;
int limit[15];
bool cnt[SIZE][15],vis[15];
int link[15][SIZE],num[SIZE];
int temp[15];

bool dfs(int lt)
{
    for(int i=1; i<=M; i++)
    {
        if(cnt[lt][i] && !vis[i])
        {
            vis[i] = true;
            if(num[i] < limit[i])
            {
                link[i][++num[i]] = lt;
                return true;
            }
            for(int j=1; j<=num[i]; j++)
            {
                if(dfs(link[i][j]))
                {
                    link[i][j] = lt;
                    return true;
                }
            }
        }
    }
    return false;
}

int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        ans = 0;
        int t;
        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=M; j++)
            {
                scanf("%d",&t);
                cnt[i][j] = t? true:false;
            }
        }
        for(int i=1; i<=M; i++)
            scanf("%d",&limit[i]);
        memset(link,0,sizeof(link));
        memset(num,0,sizeof(num));
        for(int i=1; i<=N; i++)
        {
            memset(vis,0,sizeof(vis));
            if(!dfs(i))
            {
                ans = 1;
                break;
            }
        }
        if(ans == 0) puts("YES");
        else puts("NO");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值