1044. Shopping in Mars (25)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M ).Whenmakingthepayment,thechaincanbecutatanypositionforonlyonceandsomeofthediamondsaretakenoffthechainonebyone.Onceadiamondisoffthechain,itcannotbetakenback.Forexample,ifwehaveachainof8diamondswithvaluesM 3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 … DN (Di<=103 for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print “i-j” in a line for each pair of i <= j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output “i-j” for pairs of i <= j such that Di + … + Dj > M with (Di + … + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

本题对于时间复杂度很高,在确定左端点后,如何快速确定右端点。如果能想到用查找算法的话,什么查找算法都行,我用的二分法。问题就迎刃而解了。
用动态规划做了半天,真是。。
本题有两个比较重要的点,

int f[100005];//f[i]表示从1-i的链上分数之和
//二分法求解
int findbest(int i,int n,int m){
    int l=i+1,r=n;
    while(r>l)
    {
        int mid=(l+r)/2;
        if(f[mid]-f[i]>=m)
            r=mid;
        else l=mid+1;
    }
    return l;
}

代码如下

#include<iostream>
#include<vector>
int f[100005];//f[i]表示从1-i的链上分数之和
#define max 100000005
using namespace std;
struct node{
    int i,j;
    node(int a,int b){i=a,j=b;}
};
int findbest(int i,int n,int m){
    int l=i+1,r=n;
    while(r>l)
    {
        int mid=(l+r)/2;
        if(f[mid]-f[i]>=m)
            r=mid;
        else l=mid+1;
    }
    return l;
}
int main(){
    freopen("in.txt","r",stdin);
    int n,m,k=1;
    cin>>n>>m;
    f[0]=0;
    vector <node> out;
    for(int i=1;i<=n;i++){
        cin>>f[i];
        f[i]+=f[i-1];
    }
    int min=max;
    for(int i=0;i<n;i++)
    {
        int find=findbest(i,n,m);
        if(f[find]-f[i]>=m){
            if(f[find]-f[i]<min){
                min=f[find]-f[i];
                out.clear();
                out.push_back(node(i+1,find));
            }
            else if(f[find]-f[i]==min){
                out.push_back(node(i+1,find));
            }
        }
    }
    for(int i=0;i<out.size();i++)
    {
        printf("%d-%d\n",out[i].i,out[i].j);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值