UVA 128 Software CRC(数论 进制转化)

Software CRC 

You work for a company which uses lots of personal computers. Your boss, Dr Penny Pincher, has wanted to link the computers together for some time but has been unwilling to spend any money on the Ethernet boards you have recommended. You, unwittingly, have pointed out that each of the PCs has come from the vendor with an asynchronous serial port at no extra cost. Dr Pincher, of course, recognizes her opportunity and assigns you the task of writing the software necessary to allow communication between PCs.

You've read a bit about communications and know that every transmission is subject to error and that the typical solution to this problem is to append some error checking information to the end of each message. This information allows the receiving program to detect when a transmission error has occurred (in most cases). So, off you go to the library, borrow the biggest book on communications you can find and spend your weekend (unpaid overtime) reading about error checking.

Finally you decide that CRC (cyclic redundancy check) is the best error checking for your situation and write a note to Dr Pincher detailing the proposed error checking mechanism noted below.

CRC Generation

The message to be transmitted is viewed as a long positive binary number. The first byte of the message is treated as the most significant byte of the binary number. The second byte is the next most significant, etc. This binary number will be called ``m'' (for message). Instead of transmitting ``m'' you will transmit a message, ``m2'', consisting of ``m'' followed by a two-byte CRC value.

The CRC value is chosen so that ``m2'' when divided by a certain 16-bit value ``g'' leaves a remainder of 0. This makes it easy for the receiving program to determine whether the message has been corrupted by transmission errors. It simply divides any message received by ``g''. If the remainder of the division is zero, it is assumed that no error has occurred.

You notice that most of the suggested values of ``g'' in the book are odd, but don't see any other similarities, so you select the value 34943 for ``g'' (the generator value).

Input and Output

You are to devise an algorithm for calculating the CRC value corresponding to any message that might be sent. To test this algorithm you will write a program which reads lines (each line being all characters up to, but not including the end of line character) as input, and for each line calculates the CRC value for the message contained in the line, and writes the numeric value of the CRC bytes (in hexadecimal notation) on an output line. Each input line will contain no more than 1024 ASCII characters. The input is terminated by a line that contains a # in column 1. Note that each CRC printed should be in the range 0 to 34942 (decimal).

Sample Input

this is a test

A
#

Sample Output

77 FD 
00 00
0C 86

题意:自己没看懂。。看了别人题解才懂的。。说白了。就是给一个字符串,字符有256种,所以可以看成一个256进制数,然后要补上两个数字使得该数字能被34942整除,最后输出这数字(需要转化为16进制输出)

思路:知道题意就很水了。。进制转化,取模在过程中取即可。

代码:

#include <stdio.h>
#include <string.h>
const int MOD = 34943;
char str[1111], out[5];
int i;
long long num;

int main() {
	while (gets(str) && str[0] != '#') {
		strcpy(out, "0000");
		int len = strlen(str);
		long long ans = 0;
		for (i = 0; i < len; i ++) {
			ans = ((ans << 8) + str[i]) % MOD;
		}
		ans = (ans << 16) % MOD;
		num = MOD - ans;
		if (str[0] == '\0')
			num = 0;
		i = 3;
		while (num != 0) {
			int res = num % 16;
			if (res < 10)
				out[i --] = res + '0';
			else
				out[i --] = res - 10 + 'A';
			num /= 16;
		}
		printf("%c%c %c%c\n", out[0], out[1], out[2], out[3]);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值