Simpsons’ Hidden Talents
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2417 Accepted Submission(s): 912
Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
The lengths of s1 and s2 will be at most 50000.
Sample Input
clinton homer riemann marjorie
Sample Output
0 rie 3
求两个串前缀和后缀的最长匹配
思路:两个串接起来去KMP,next[n]就是答案,但是要注意长度不能超过原来两个串的长度
代码:
#include <stdio.h>
#include <string.h>
const int N = 50005;
#define min(a,b) ((a)<(b)?(a):(b))
char s1[N], s2[N], s3[N * 2];
int next[N * 2];
void get_next(char *seq, int m) {
next[0] = -1;
int j = next[0];
for (int i = 1; i < m; i++) {
while (j >= 0 && seq[i] != seq[j + 1]) j = next[j];
if (seq[i] == seq[j + 1]) j++;
next[i] = j;
}
}
bool kmp(char *seq, char *seq1, int n, int m) {
int j = next[0], ans = 0;
for (int i = 0; i < n; i++) {
while (j >= 0 && seq[i] != seq1[j + 1]) j = next[j];
if (seq[i] == seq1[j + 1]) j++;
if (j == m - 1) {
//根据题意
}
}
return false;
}
int main() {
while (~scanf("%s%s", s1, s2)) {
int len1 = strlen(s1), len2 = strlen(s2);
strcpy(s3, s1); strcpy(s3 + len1, s2);
int len3 = strlen(s3);
get_next(s3, len3);
int ans = min(min(len1, len2), next[len3 - 1] + 1);
for (int i = 0; i < ans; i++)
printf("%c", s1[i]);
if (ans) printf(" ");
printf("%d\n", ans);
}
return 0;
}