杭电1002(a+b)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

分析:这道题需要用字符串进行输入,同时需要判断a和b谁长,之后两个字符串转化为数组类型进行相加

同时输出时注意格式

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
char a[1010],b[1010];
int x[1010],y[1010],z[1010];
int main()
{
    int n,i,j,lena,lenb,c,d,t,k=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        k++;
        int x[1010]={0},y[1010]={0},z[1010]={0};//数组初始化,很重要!
        scanf("%s %s",a,b);
        lena=strlen(a);
        lenb=strlen(b);
        if(lena>lenb)//判断字符串长度问题(a>b的情况)
        {
        for(j=0;j<lena;j++)//转化为数字类型
        {
            x[j]=a[j]-48;
        }
        for(j=0;j<lenb;j++)//转化为数字类型
        {
            y[j]=b[j]-48;
        }
        for(c=0;c<lena-lenb;c++)
        {
            z[c]=x[c];
        }
        for(c=lena-lenb;c<lena;c++)
        {
            z[c]=x[c]+y[c-lena+lenb];
        }
        for(c=lena-1;c>0;c--)
        {
            if(z[c]>=10)
            {
                z[c]=z[c]-10;
                z[c-1]++;
            }
        }
        printf("Case %d:\n",k);//格式问题,需要注意!
        printf("%s + %s = ",a,b);
        for(c=0;c<lena;c++)
        {
            printf("%d",z[c]);
        }
        if(n!=k)
        printf("\n\n");
        else
            printf("\n");
        }
        else//(a<b的情况)
        {
        for(j=0;j<lena;j++)
        {
            x[j]=a[j]-48;
        }
        for(j=0;j<lenb;j++)
        {
            y[j]=b[j]-48;
        }
        for(c=0;c<lenb-lena;c++)
        {
            z[c]=y[c];
        }
        for(c=lenb-lena;c<lenb;c++)
        {
            z[c]=y[c]+x[c-lenb+lena];
        }
        for(c=lenb-1;c>0;c--)
        {
            if(z[c]>=10)
            {
                z[c]=z[c]-10;
                z[c-1]++;
            }
        }
        printf("Case %d:\n",k);
        printf("%s + %s = ",a,b);
        for(c=0;c<lenb;c++)
        {
            printf("%d",z[c]);
        }
        if(n!=k)
        printf("\n\n");
        else
            printf("\n");
        }
            }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值