POJ 1276

http://poj.org/problem?id=1276
Cash Machine

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36726 Accepted: 13317

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

题意:这是一道关于取款机的题目,题目给出要取出的钱cash,给出钱面额的种类个数N,给出面额的张数Nk以及面额的数值Dk,求最多够取出多少钱来(接近cash或者等于cash)
这个题目,是个多个背包题,说实话动态规划的题目不熟练,也只是看了被人的才知道这是一个多个背包的题,觉得动态规划好难好难啊。。。。看别人的代码知道做,but自己就是不会。。。求大神指点迷津!
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int cash,n;//金额,面额种类
int a[100000];//一种面额的数量
int b[100000];//面额值
int dp[100000];//记录
int count[100000];//记录面额的数量
int main()
{

    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        memset(dp,0,sizeof(dp));//初始化
        for(int i=1;i<=n;i++)
        {
            memset(count,0,sizeof(count));
            for(int j=b[i];j<=cash;j++)
            {
                if(dp[j]<dp[j-b[i]]+b[i]&&count[j-b[i]]<a[i])//根据钱的多少作为一种状态,
                //如果开始的面额最多拼出来的金额要大于现在拼出来的金额,就无须进去,改变现在的状态,如果用的一种面额的数量大于
                //原来有的数量,那么也就无需改变现在的状态
                {
                    dp[j]=dp[j-b[i]]+b[i];//记录从一种面额到所需要拼出的钱数的最大钱数的状态
                    count[j]=count[j-b[i]]+1;//记录所用一种面额的数量
                }
            }
        }
        printf("%d\n",dp[cash]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值