POJ 2635 The Embarrassed Cryptographer

The Embarrassed Cryptographer
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10450 Accepted: 2752

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.  
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100  and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

Source

这题大意啊 ,确定思路后不断的Wa,对着数据无奈的发现我 数组开小了 了,总的思路来说还是枚举 接近700ms过了
#include <stdio.h>
#include <string.h>
#include <math.h>
int a[1000001];
char s1[101];
__int64 b[30];
int main()
{
    __int64 i,j,n,m,t,l,weishu;
    __int64 s;
    memset(a,0,sizeof(a));
    for(i=2;i<=1000000;i++)
    {
        if(a[i]==0)
        {
            for(j=2;i*j<=1000000;j++)
            {
                a[i*j]=1;
            }
        }
    }
    while(scanf("%s %I64d",s1,&m)!=EOF)
    {
        l=strlen(s1);
        for(i=0;i<=l-1;i++)
        {
            if(s1[i]!='0')
            {
                break;
            }
        }
        if(i==l&&m==0)
        {
            break;
        }
        memset(b,0,sizeof(b));
        for(i=0,j=0,s=0;i<=l-1;i++)
        {
            b[j]=b[j]*10+(s1[i]-'0');
            s++;
            if((i+1)%9==0||i==l-1)
            {
                j++;
                weishu=s;
                s=0;
            }
        }
        n=j;
        for(i=2;i<=m-1;i++)
        {
            if(a[i]==0)
            {
                for(j=0,s=0;j<=n-1;j++)
                {
                    if(j!=n-1)
                    {
                        s=s*1000000000+b[j];
                    }else
                    {
                        for(t=1;t<=weishu;t++)
                        {
                            s=s*10;
                        }
                        s+=b[j];
                    }
                    s=s%i;
                }
                if(s==0)
                {
                    break;
                }
            }
        }
        if(i==m)
        {
            printf("GOOD\n");
        }else
        {
            printf("BAD %I64d\n",i);
        }
    }
    return 0;
}

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值