POJ 2503 Babelfish map做法

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 31965 Accepted: 13732

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source



map的基础题。比较大的输入输出,所以重载new,delete运算符。但其实这题输入输出也不是很大,没什么必要。
代码如下:
#include <iostream>
#include<cstdio>
#include<map>
#include<string>
using namespace std;
//手动分配内存空间
char buf[50000000];
int sizet =0;


void* operator new(size_t size){
    void *p = buf + sizet;
    sizet  += size;
    return p;


}
void operator delete(void* p){
}

//
int main()
{
char e[11],f[11],str[25];
map<string,string>t;
for(;;)
{
   gets(str);
   //cin>>str;
   if(str[0]=='\0') break;//str[0]=='\n'无效,应该是gets和cin等的运行机制问题。若要保险,再加一句:str[0]=='\n'.
   sscanf(str,"%s%s",e,f);//从str读取
   t[f]=e;
}
while(scanf("%s",str)!=EOF)
{
   string s=t[str];
   if (s.length()==0)//string类对象s的函数length()
   printf("eh\n");
   else
   printf("%s\n",s.c_str());//转换为cstring类型的数据,用s.c_str()函数
}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值