UVALive - 3177 Beijing Guards

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Beijing was once surrounded by four rings of city walls: the Forbidden City Wall, the Imperial City Wall, the Inner City Wall, and finally the Outer City Wall. Most of these walls were demolished in the 50s and 60s to make way for roads. The walls were protected by guard towers, and there was a guard living in each tower. The wall can be considered to be a large ring, where every guard tower has exaetly two neighbors.

The guard had to keep an eye on his section of the wall all day, so he had to stay in the tower. This is a very boring job, thus it is important to keep the guards motivated. The best way to motivate a guard is to give him lots of awards. There are several different types of awards that can be given: the Distinguished Service Award, the Nicest Uniform Award, the Master Guard Award, the Superior Eyesight Award, etc. The Central Department of City Guards determined how many awards have to be given to each of the guards. An award can be given to more than one guard. However, you have to pay attention to one thing: you should not give the same award to two neighbors, since a guard cannot be proud of his award if his neighbor already has this award. The task is to write a program that determines how many different types of awards are required to keep all the guards motivated.

Input

The input contains several blocks of test eases. Each case begins with a line containing a single integer l$ \le$n$ \le$100000, the number of guard towers. The next n lines correspond to the nguards: each line contains an integer, the number of awards the guard requires. Each guard requires at least 1, and at most l00000 awards. Guard i and i + 1 are neighbors, they cannot receive the same award. The first guard and the last guard are also neighbors.

The input is terminated by a block with n = 0.

Output

For each test case, you have to output a line containing a single integer, the minimum number x of award types that allows us to motivate the guards. That is, if we have x types of awards, then we can give as many awards to each guard as he requires, and we can do it in such a way that the same type of award is not given to neighboring guards. A guard can receive only one award from each type.

Sample Input

3
4
2
2
5
2
2
2
2
2
5
1
1
1
1
1
0

Sample Output

8
5
3

Source




分析:
能想到二分法估计就不难了吧。刘汝佳大白书里的题,2004年欧洲区域赛中欧赛区题目。
ac代码:
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100000+10;
int r[maxn],left0[maxn],right0[maxn];
int n;


bool test(int p)
{
    int x=r[1],y=p-r[1];
    left0[1]=x;right0[1]=0;
    for(int i=2;i<=n;i++)
    {
        if(i%2==0)
        {
            left0[i]=min(x-left0[i-1],r[i]);
            right0[i]=r[i]-left0[i];
        }
        else
        {
            right0[i]=min(y-right0[i-1],r[i]);
            left0[i]=r[i]-right0[i];
        }
    }
    return left0[n]==0;
}


int main()
{
   while(scanf("%d",&n)==1&&n)
   {
       int L=0,R=0;//
       for(int i=1;i<=n;i++)
       scanf("%d",&r[i]);
       if(n==1) //n==1特殊判断
      {
          printf("%d\n",r[1]);
          continue;
      }
       r[n+1]=r[1];
       for(int i=1;i<=n;i++)
       L=max(r[i]+r[i+1],L);
       if(n%2==1)
       {
           for(int i=1;i<=n;i++)
           R=max(r[i]*3,R);
           while(R-L>0)
           {
               int M=L+(R-L)/2;
               if(test(M))
               R=M;
               else L=M+1;
           }
       }
       printf("%d\n",L);
   }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值