UVA - 10010 Where's Waldorf?

Given a m by n grid of letters, (1 ≤ m, n ≤ 50), and a list of words, find the location in the grid at
which the word can be found.
A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters
in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The
matching can be done in any of the eight directions either horizontally, vertically or diagonally through
the grid.
Input
The input begins with a single positive integer on a line by itself indicating the number
of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.
The input begins with a pair of integers, m followed by n, 1 ≤ m, n ≤ 50 in decimal notation on a
single line. The next m lines contain n letters each; this is the grid of letters in which the words of the
list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters,
another integer k appears on a line by itself (1 ≤ k ≤ 20). The next k lines of input contain the list of
words to search for, one word per line. These words may contain upper and lower case letters only (no
spaces, hyphens or other non-alphabetic characters).
Output
For each test case, the output must follow the description below. The outputs of two
consecutive cases will be separated by a blank line.
For each word in the word list, a pair of integers representing the location of the corresponding
word in the grid must be output. The integers must be separated by a single space. The first integer
is the line in the grid where the first letter of the given word can be found (1 represents the topmost
line in the grid, and m represents the bottommost line). The second integer is the column in the grid
where the first letter of the given word can be found (1 represents the leftmost column in the grid, and
n represents the rightmost column in the grid). If a word can be found more than once in the grid,
then the location which is output should correspond to the uppermost occurence of the word (i.e. the
occurence which places the first letter of the word closest to the top of the grid). If two or more words
are uppermost, the output should correspond to the leftmost of these occurences. All words can be
found at least once in the grid.
Sample Input
1
8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert
Sample Output
2 5
2 3
1 2

7 8




分析:

【大意】:

输入:

给你一个由字母组成的网格,M行N列。寻找一个单词在网格中的位置。一个单词匹配网格中联系不间断的字母。可以沿任意方向匹配,一共可以匹配八个方向。忽略大小写。

需要匹配的字符串有K个。

输出:

每组输出之间都一行空行。

m nm代表匹配的最上面的行

      n代表匹配的最下面的行

如果结果有多个,只输出匹配串。要求:匹配串的第一个字母必须是最高最左的。结果至少有一个。



其实应该在判断不能继续往下的时候及时终止。这个解法不好。

【代码】:

#include <iostream>
#include <cctype>
#include <cstring>
using namespace std;


//表格长宽
int m,n;


// 保存最终查找到的位置。
int positionX;
int positionY;


//存储表格数据
char data[60][60];


//八个查找方向
int dx[] = {1, -1, 0, 0, -1, 1, 1, -1};
int dy[] = {1, -1, 1, -1, 0, 0, -1, 1};


// 判断是否可以取下一个字母
int ifCanNext(int x, int y)
{
    if (x >= 0 && x < m && y >= 0 && y < n) 
        return 1;
    else return 0;
}


void findPosition(char input[])
{
int i, j, k;
int inputLen = strlen(input);
for (i = 0; i < m; i++)
{
for (j = 0; j < n; j++)
{
for (k = 0; k < 8; k++)
{
char str[50];
str[0] = data[i][j];
int newx = i + dx[k];
int newy = j + dy[k];
int c = 1;
while (ifCanNext(newx, newy))
{
str[c++] = data[newx][newy];
if (c == inputLen) break;
newx += dx[k];
newy += dy[k];
}
str[c] = '\0';
if (strcmp(str, input) == 0)
{
positionX = i + 1;
positionY = j + 1;
return;
}
}
}
}
return;
}


int main()
{
//freopen("E:\\in.txt","r",stdin);
int i,j;
int t = 0;
int N; // 测试实例
cin >> N;
while(N--)
{
if(t != 0)
cout << endl;
t++;
cin >> m >> n;

//read the data[][]
for(i=0; i<m; i++)
{
for(j=0; j<n; j++)
{
cin >> data[i][j];
data[i][j] = tolower(data[i][j]);
}
}

int t; //test case
cin >> t;
while(t--)
{
char str[60];
cin >> str;
int len = strlen(str);
for (j = 0; j < len; j++)
{
str[j] = tolower(str[j]);
}
findPosition(str);
cout << positionX << " " << positionY << endl;
}
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值