UVA - 644 Immediate Decodability

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the
prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that
no two codes within a set of codes are the same, that each code has at least one bit and no more than
ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a
group contains a collection of zeroes and ones representing a binary code for a different symbol. Each
group is followed by a single separator record containing a single 9; the separator records are not part
of the group. Each group is independent of other groups; the codes in one group are not related to
codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately
decodable, and should print a single output line giving the group number and stating whether the
group is, or is not, immediately decodable.
Note: The Sample Input describes the examples above.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable

Set 2 is not immediately decodable





分析:

字符串匹配。

暴力可过。

代码:

#include<stdio.h>
#include<string.h>
char str[100][100];
int com(int t,int x)
{
    int n,m,i;
    n=strlen(str[t]);
    m=strlen(str[x]);
    n=(n>m)?m:n;
    for(i=0;i<n;i++)
    {
        if(str[t][i]!=str[x][i])
        return 1;
    }
    return 0;
}
int main()
{
    int t,leap,i;
    t=0;
    leap=0;
int cas=0;
    while(gets(str[t])!=NULL)
    {

        if(str[t][0]=='9')
        {
cas++;

            if(leap)
                printf("Set %d is not immediately decodable\n",cas);
            else
                printf("Set %d is immediately decodable\n",cas);
            t=0;
            leap=0;
            continue;
        }
        for(i=0;i<t;i++)
        {
            if(com(t,i)==0)
            {
                leap=1;
            }
        }
        t++;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
infinite-scroll-immediate是一个属性,用于控制是否立即执行加载方法,以防初始状态下内容无法撑满容器。默认情况下,infinite-scroll-immediate的值是false,即不会立即执行加载方法。如果需要在初始状态下就执行加载方法,可以将infinite-scroll-immediate的值设置为true。这样,在组件初始化时就会执行加载方法。\[2\] #### 引用[.reference_title] - *1* [vue-infinite-scroll无限滚动组件](https://blog.csdn.net/weixin_45807026/article/details/125621351)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [Element UI - v-infinite-scroll无限滚动组件](https://blog.csdn.net/m0_70547044/article/details/128517328)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *3* [【Vue】实现无限滚动加载](https://blog.csdn.net/NineWaited/article/details/126387768)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值