POJ - 3278 Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
一个人在x处,通过x-1,x+1,x*2的方式最后到达k处。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
const int N=100000;
int step[N];
/*
设置一个队列,让顶点进队,求出三种走法到达的位置,
将新位置进队,更新队首,重复求出三种新的位置,直至到达k。
*/
int bfs(int n,int k)
{
    queue<int> q;
    q.push(n);
    while(!q.empty())
    {
        int point=q.front();//取队首
        q.pop();//弹出队列
        if(point==k)//到达k处
        {
            return step[point];
        }
        if(point-1>=0&&!step[point-1])//符合要求且没有访问过
        {
            q.push(point-1);
            step[point-1]=step[point]+1;
        }
        if(point+1<=N&&!step[point+1])
        {
            q.push(point+1);
            step[point+1]=step[point]+1;
        }
        if(point*2<=N&&!step[point*2])
        {
            q.push(point*2);
            step[point*2]=step[point]+1;
        }
    }
    return 0;
}

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)==2)
    {
        memset(step,0,sizeof(step));
        if(n>=k)//这是只能通过n-1到达k
        {
            printf("%d\n",n-k);
        }
        else
        {
            printf("%d\n",bfs(n,k));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值