POJ - 3660 Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

有n头牛比赛,m种比赛结果,求一共有多少头牛的排名被确定了,其中如果a战胜b,b战胜c,则也可以说a战胜c,即可以传递胜负。
之前只知道Floyd是求最短路的,百度一下还可以求传递闭包的问题。
一头牛的排名被确定就是根据它可以知道其他n-1头牛赢了这头牛或输给这头牛,即一个顶点的出度与入度 相加=顶点数-1,就可以确定这个顶点的排名了

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,m;
int w[110][110];

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(w[i][k]&&w[k][j])
                {
                    w[i][j]=1;//用floyd扩展关系
                }
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        int a,b;
        memset(w,0,sizeof(w));//初始化
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            w[a][b]=1;
        }
        floyd();
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            int ans=0;
            for(int j=1;j<=n;j++)
            {
                if(i!=j)
                {
                    if(w[i][j]||w[j][i])
                    {
                        ans++;//出度入度和
                    }
                }
            }
            if(ans==n-1)
            {
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值