C - 2D Plane 2N Points(二分图匹配 匈牙利算法)

C - 2D Plane 2N Points
Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement
On a two-dimensional plane, there are N red points and N blue points. The coordinates of the i-th red point are (ai,bi), and the coordinates of the i-th blue point are (ci,di).

A red point and a blue point can form a friendly pair when, the x-coordinate of the red point is smaller than that of the blue point, and the y-coordinate of the red point is also smaller than that of the blue point.

At most how many friendly pairs can you form? Note that a point cannot belong to multiple pairs.

Constraints
All input values are integers.
1≤N≤100
0≤ai,bi,ci,di<2N
a1,a2,…,aN,c1,c2,…,cN are all different.
b1,b2,…,bN,d1,d2,…,dN are all different.
Input
Input is given from Standard Input in the following format:

N
a1 b1
a2 b2
:
aN bN
c1 d1
c2 d2
:
cN dN
Output
Print the maximum number of friendly pairs.

Sample Input 1
Copy
3
2 0
3 1
1 3
4 2
0 4
5 5
Sample Output 1
Copy
2
For example, you can pair (2,0) and (4,2), then (3,1) and (5,5).

Sample Input 2
Copy
3
0 0
1 1
5 2
2 3
3 4
4 5
Sample Output 2
Copy
2
For example, you can pair (0,0) and (2,3), then (1,1) and (3,4).

Sample Input 3
Copy
2
2 2
3 3
0 0
1 1
Sample Output 3
Copy
0
It is possible that no pair can be formed.

Sample Input 4
Copy
5
0 0
7 3
2 2
4 8
1 6
8 5
6 9
5 4
9 1
3 7
Sample Output 4
Copy
5
Sample Input 5
Copy
5
0 0
1 1
5 5
6 6
7 7
2 2
3 3
4 4
8 8
9 9
Sample Output 5
Copy
4
将满足条件的i,j存入邻接矩阵后 ,套匈牙利算法模板

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 510;
int uN,vN;//u,v的数目,使用前面必须赋值
int g[MAXN][MAXN];//邻接矩阵
int linker[MAXN];
bool used[MAXN];

bool dfs(int u)
{
    for(int v = 0; v < vN;v++)
    if(g[u][v] && !used[v])
    {
        used[v] = true;
        if(linker[v] == -1 || dfs(linker[v]))
        {
            linker[v] = u;
            return true;
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    memset(linker,-1,sizeof(linker));
    for(int u = 0;u < uN;u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u))res++;
    }
    return res;
}

int main()
{
    int n;
    int a[110],b[110],c[110],d[110];
    while(scanf("%d",&n)!=EOF){
        uN=vN=n;
        for(int i=0;i<n;i++){
            scanf("%d%d",&a[i],&b[i]);
        }
        for(int i=0;i<n;i++){
            scanf("%d%d",&c[i],&d[i]);
        }
        memset(g,0,sizeof(g));
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(a[i]<c[j]&&b[i]<d[j]){
                    g[i][j]=1;
                }
            }
        }
        printf("%d\n",hungary());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值