A. Rikka with Chess

A. Rikka with Chess
Time Limit: 1000msMemory Limit: 65536KB 64-bit integer IO format: Java class name:
Submit Status PID: 5761
Yuta gives Rikka a chess board of size $n \times m$.

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.

一个n×m的黑白相间的棋盘,每次可以选择一个矩形把其中的所有格子反色。问把所有格子变成一种颜色时的最少操作次数。
Input
The first line contains a number T(T <= 10) ——The number of the testcases.

Each testcase contains two numbers $n,m(n <= 10^9, m <= 10^9)$.

Output
For each testcase, print a single number which represents the answer.

Sample Input
3
1 2
2 2
3 3
Sample Output
1
2

2

属于规律题

#include <iostream>
using namespace std;
int main()
{
	int t,n,m;
	cin>>t;
	while(t--) {
		cin>>n>>m;
		cout<<n/2+m/2<<endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值