数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli

提示

 

来源

ma6174

示例程序

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    int data;
    struct node *lchild,*rchild;
}tree;
tree *creat(char dlr[],char ldr[],int n)
{
    tree *root;
    char *p;
    if(n == 0)
        root = NULL;
    else
    {
        root = (tree *)malloc(sizeof(tree));
        root->data = dlr[0];
        for(p = ldr;p != '\0';p++)
            if(*p == dlr[0])
            break;
        int t;
        t = p - ldr;
        root->lchild = creat(dlr+1, ldr, t);
        root->rchild = creat(dlr+t+1, p+1, n-t-1);
    }
    return root;
}
void lrd(tree *root)
{
    if(root == NULL)
        return ;
    else
    {
        lrd(root->lchild);
        lrd(root->rchild);
        printf("%c",root->data);
    }
}
void layer(tree *root)
{
    int base = 0,top = 0;
    tree *s[1000];
    s[top++] = root;
    while(base < top)
    {
        if(s[base])
        {
            root = s[base];
            printf("%c",root->data);
            if(root->lchild)
            {
                s[top++] = root->lchild;
            }
            if(root->rchild)
            {
                s[top++] = root->rchild;
            }
        }
        base++;
    }
}
int main()
{
    int n,t;
    tree *root;
    char dlr[1000],ldr[1000];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",dlr,ldr);
        n = strlen(dlr);
        root = creat(dlr,ldr,n);
        lrd(root);
        printf("\n");
        layer(root);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值