数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory limit: 65536K

题目描述

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

输入

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

输出

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

示例输入

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

示例输出

Yes
No
No

提示

 

来源

xam 

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    int data;
    struct node *lchild,*rchild;
}tree;
int f;
void creat(tree *&root,int key)
{
    if(root == NULL)
    {
        root = (tree *)malloc(sizeof(tree));
        root->data = key;
        root->lchild = root->rchild = NULL;
    }
    else
    {
        if(root->data > key)
            creat(root->lchild,key);
        else
            creat(root->rchild,key);
    }
}
void judge(tree *root1,tree *root2)
{
    if(!root1 && !root2)
    {
        return ;
    }
    else if((!root1 && root2) || (root1 && !root2))
    {
        f = 1;
        return ;
    }
    else if(root1->data == root2->data)
    {
        judge(root1->lchild,root2->lchild);
        judge(root1->rchild,root2->rchild);
    }
    else
    {
        f = 1;
        return ;
    }
}
int main()
{
    int n,m;
    int a[100],b[100];
    tree *root1,*root2;
    while(~scanf("%d",&n) && n != 0)
    {
        scanf("%d",&m);
        root1 = NULL;
        for(int i = 0;i < n;i++)
        {
            scanf("%d",&a[i]);
            creat(root1,a[i]);
        }
        while(m--)
        {
            root2 = NULL;
            f = 0;
            for(int i = 0;i < n;i++)
            {
                scanf("%d",&b[i]);
                creat(root2,b[i]);
            }
            judge(root1,root2);
            if(f)
                printf("No\n");
            else
                printf("Yes\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值