1142 Maximal Clique (25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

给出一个图,然后输出几组测试数据,判断每组 数据:如果不是完全图,输出not a clique,如果是完全图,但是如果可以加入一个点后,仍然是完全图,此时输出not maximal,即不是最大完全图。如果不存在这样的点,则是最大完全图,输出yes

#include<iostream>
#include<vector>
using namespace std;
int inf = 100009;
int mp[201][201];
void init(int n){
	for(int i = 0;i <= n;i++){
		for(int j = 0;j <= n;j++){
			if(i==j){
				mp[i][j] = inf;
			}else{
				mp[i][j] = 0; 	
			}
		}
	}
}
int main(){
	int n,m,k;
	cin >> n >> m;
	init(n);
	while(m--){
		int a,b;
		cin >> a >> b;
		mp[a][b] = mp[b][a] = 1;
	}
	
	int cnt;
	cin >> cnt;
	while(cnt--){
		
		vector<int> v;
		vector<int> p(n+1,0);
		int k;
		cin >> k;
		while(k--){
			int c;
			cin >> c;
			v.push_back(c);
			p[c] = 1; // 标记此点是否给出 
		}
		int flag = 0;//判断是否是clique 
		for(int i = 0;i < v.size()-1;i++){   
			for(int j = i+1;j < v.size();j++){
				if(mp[v[i]][v[j]] == 0){
					flag = 1;
					break;
				}
			}
			if(flag)
				break;
		}
		
		if(flag){
			cout << "Not a Clique" << endl;
		}else{
			int ans = 0;      //判断maximal clique 
			for(int i = 1;i <= n;i++){
				if(p[i] == 0){
					int j;
					for(j = 0;j < v.size();j++){
						if(mp[i][v[j]] == 0){
							break;
						}
					}
					if(j == v.size()){
						ans = 1;
						break;
					}
				}
			}
			if(ans){
				cout << "Not Maximal" << endl;
			}else{
				cout << "Yes" << endl;
			}
		}
	}
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值