HDU 5380 Travel with candy 单调队列

链接

题解链接:http://www.cygmasot.com/index.php/2015/08/16/hdu_5380

题意:

n C

一条数轴上有n+1个加油站,起点在0,终点在n。车的油箱容量为C

下面n个数字表示每个加油站距离起点的距离。

下面n+1行表示每个加油站买进和卖出一单位油的价格。油可以买也可以卖。

问开到终点的最小花费。

思路:

把油箱保持装满,然后维护一个价格单调递增的队列。


#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <stdio.h>  
#include <iostream>  
#include <algorithm>  
#include <sstream>  
#include <stdlib.h>  
#include <string.h>  
#include <limits.h>  
#include <vector>  
#include <string>  
#include <time.h>  
#include <math.h>  
#include <iomanip>  
#include <queue>  
#include <stack>  
#include <set>  
#include <map>  
const int inf = 1e9;
const double eps = 1e-8;
const double pi = acos(-1.0);
template <class T>
inline bool rd(T &ret) {
	char c; int sgn;
	if (c = getchar(), c == EOF) return 0;
	while (c != '-' && (c<'0' || c>'9')) c = getchar();
	sgn = (c == '-') ? -1 : 1;
	ret = (c == '-') ? 0 : (c - '0');
	while (c = getchar(), c >= '0'&&c <= '9') ret = ret * 10 + (c - '0');
	ret *= sgn;
	return 1;
}
template <class T>
inline void pt(T x) {
	if (x < 0) { putchar('-'); x = -x; }
	if (x > 9) pt(x / 10);
	putchar(x % 10 + '0');
}
using namespace std;
const int N = 2e5 + 10;
typedef long long ll;
typedef pair<int, int> pii;
ll n, c;
ll in[N], out[N], dis[N];
ll work() {
	ll ans = c*in[0];
	deque<ll> In, o;
	In.push_back(in[0]); o.push_back(c);
	for (int i = 1; i <= n; i++)
	{
		ll tmp = dis[i];
		while (tmp) {
			ll LEF = o.front();
			ll mi = min(tmp, LEF);
			LEF -= mi;
			tmp -= mi;
			o.pop_front();
			if(LEF)
				o.push_front(LEF);
			else
				In.pop_front();
		}
		ll tot = dis[i]; tmp = 0;
		while (!In.empty()) {
			if (In.front() <= out[i])
			{
				tmp += o.front();
				ans -= out[i]*o.front();
				o.pop_front();
				In.pop_front();
			}
			else break;
		}
		if (tmp) {
			ans += out[i] * tmp;
			o.push_front(tmp);
			In.push_front(out[i]);
		}
		while (!In.empty()) {
			if (In.back() >= in[i])
			{
				tot += o.back();
				ans -= In.back()*o.back();
				o.pop_back();
				In.pop_back();
			}
			else break;
		}
		o.push_back(tot);
		In.push_back(in[i]);
		ans += in[i] * tot;
	}
	while (!In.empty()) {
		ans -= o.front() * In.front();
		In.pop_front(); o.pop_front();
	}
	return ans;
}
int main() {
	int T; rd(T);
	while (T--) {
		rd(n); rd(c);
		for (int i = 1; i <= n; i++)rd(dis[i]);
		for (int i = n; i > 1; i--)dis[i] -= dis[i - 1];
		for (int i = 0; i <= n; i++)rd(in[i]), rd(out[i]);		
		pt(work()); puts("");
	}
	return 0;
}
/*
1
3 9
2 4 6
8 2
4 3
6 3
9 6

1
4 9
4 9 12 18
5 1
7 6
3 2
4 2
8 6

1
4 5
2 4 8 10
2 1
2 1
9 3
9 8
7 2

1
9 4
2 4 5 7 8 9 11 14 15
9 8
10 5
8 2
4 3
2 1
7 3
9 6
10 8
5 3
8 5

*/

Travel with candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 104    Accepted Submission(s): 46


Problem Description
There are n+1 cities on a line. They are labeled from city 0 to city n. Mph has to start his travel from city 0, passing city 1,2,3...n-1 in order and finally arrive city n. The distance between city i and city 0 is  ai . Mph loves candies and when he travels one unit of distance, he should eat one unit of candy. Luckily, there are candy shops in the city and there are infinite candies in these shops. The price of buying and selling candies in city i is  buyi  and  selli  per unit respectively. Mph can carry at most C unit of candies.
Now, Mph want you to calculate the minimum cost in his travel plan.
 

Input
There are multiple test cases.
The first line has a number T, representing the number of test cases.
For each test :
The first line contains two numbers  N  and  C   (N2×105,C106)
The second line contains  N  numbers  a1,a2,...,an . It is guaranteed that  ai>ai1  for each  1<i<=N  .
Next  N+1  line : the i-th line contains two numbers  buyi1  and  selli1  respectively. ( selli1buyi1106 )

The sum of  N  in each test is less than  3×105 .
 

Output
Each test case outputs a single number representing your answer.(Note: the answer can be a negative number)
 

Sample Input
  
  
1 4 9 6 7 13 18 10 7 8 4 3 2 5 4 5 4
 

Sample Output
  
  
105
 

Author
SXYZ
 

Source
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值