hdu 4135 二进制搞掂容斥定理 @质因子

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 193    Accepted Submission(s): 85


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 
#include<iostream>
#define maxn 90
#define LL long long
using namespace std;
LL prime[maxn]; //所存值的质因子
LL make_ans(LL num,int m){ //num个数中与m个质因子不互质的所有个数
	int ans = 0,flag,tmp,j,i;
	for(i = 1;i<(LL)(1<<m);i++){ //1<<m是位运算,求被用到的质因子的组合数,用于后面判断奇偶!
		tmp = 1;flag = 0;
		for(j=0;j<m;j++) //判断第几个质因子被用到
			if(i&((LL)(1<<j)))/*if is used*/ //如果被用到,将被tmp乘上
				flag++,tmp*=prime[j];
			
			if(flag&1) //flag为奇数
				ans+=num/tmp;
			else
				ans-=num/tmp;
		}
	return ans;
}
int main(){
	int T,m,t=0;
	LL n,a,b,i;
	scanf("%d",&T);
	while(T--){
		scanf("%I64d%I64d%I64d",&a,&b,&n);
		/*seperate n*/
		m = 0;
		for(i=2;i*i<=n;i++){
			if(n&&n%i==0)
				prime[m++] = i; //给每个质因子赋值
			while(n&&n%i==0)
				n/=i; //限制必须是因子
		}
		if(n>1){
			prime[m++] = n;
		}
		printf("Case #%d: %I64d\n",++t,(b-make_ans(b,m))- (a-1-make_ans(a-1,m))); 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值