数据结构实验之链表五:单链表的拆分
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Example Input
10 1 3 22 8 15 999 9 44 6 1001
Example Output
4 6 22 8 44 6 1 3 15 999 9 1001
Hint
不得使用数组!
Author
#include <stdlib.h>
struct node
{
int data;
struct node * next;
};
struct node * creat(struct node * head,int n)
{
struct node * p,*tail;
head->next=NULL;///必须有这个,不然会出错
tail=head;
for(int i=0; i<n; i++)
{
p=(struct node * )malloc(sizeof(struct node ));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
};
void shuchu(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
if(p->next==NULL)
{
printf("%d\n",p->data);
}
else
{
printf("%d ",p->data);
}
p=p->next;
}
}
void chaifen(struct node * head1)///用顺序建链表拆分
{
struct node *p1,*head2,*tail1,*tail2;
head2=(struct node *)malloc(sizeof(struct node ));
head2->next=NULL;
p1=head1->next;
head1->next=NULL;
tail1=head1;
tail2=head2;
int a=0,b=0;
while(p1)
{
if(p1->data%2==0)
{
tail2->next=p1;
tail2=p1;
p1=p1->next;
a++;
}
else
{
tail1->next=p1;
tail1=p1;
p1=p1->next;
b++;
}
}
tail1->next=NULL;
tail2->next=NULL; ///1. "22 8 44 6" 已经访问完了. 2. 养成习惯,节点已记下后,应做置空操作
printf("%d %d\n",a,b);
shuchu(head2);
shuchu(head1);
};
int main()
{
int n;
scanf("%d",&n);
struct node *head;
head=(struct node * )malloc(sizeof(struct node ));///开空间的时候只能一处开
head->next=NULL;
head=creat(head,n);
chaifen(head);
return 0;
}