poj2155二维线段树

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 27530 Accepted: 10050

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0

1

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define N 1010
using namespace std;
int t,n,q,ans;
char s[5];
int sum[N<<2][N<<2];
void update2(int L,int R,int l,int r,int rtx,int rty)
{
        if(L<=l&&r<=R)
        {
                sum[rtx][rty]^=1;
                return ;
        }
        int mid=(l+r)>>1;
        if(L>mid)
                update2(L,R,mid+1,r,rtx,rty<<1|1);
        else if(R<=mid)
                update2(L,R,l,mid,rtx,rty<<1);
        else
        {
                update2(L,mid,l,mid,rtx,rty<<1);
                update2(mid+1,R,mid+1,r,rtx,rty<<1|1);
        }
}
void update(int x1,int x2,int y1,int y2,int l,int r,int rt)
{
        if(x1<=l&&r<=x2)
        {
                update2(y1,y2,1,n,rt,1);
                return ;
        }
        int mid=(l+r)>>1;
        if(x1>mid)
                update(x1,x2,y1,y2,rson);
        else if(x2<=mid)
                update(x1,x2,y1,y2,lson);
        else
        {
                update(x1,mid,y1,y2,lson);
                update(mid+1,x2,y1,y2,rson);
        }
}
void query2(int y1,int l,int r,int rtx,int rty)
{
        ans^=sum[rtx][rty];
        if(l==r)
        {
                return;
        }
        int mid=(l+r)>>1;
        if(y1<=mid)
                query2(y1,l,mid,rtx,rty<<1);
        else
                query2(y1,mid+1,r,rtx,rty<<1|1);
}
void query(int x1,int y1,int l,int r,int rt)
{
        query2(y1,1,n,rt,1);
        if(l==r)
        {
                return;
        }
        int mid=(l+r)>>1;
        if(x1<=mid)
                query(x1,y1,l,mid,rt<<1);
        else
                query(x1,y1,mid+1,r,rt<<1|1);
}
int main()
{
        scanf("%d",&t);
        while(t--)
        {
                memset(sum,0,sizeof(sum));
                scanf("%d%d",&n,&q);
                for(int i=1;i<=q;i++)
                {
                        scanf("%s",s);
                        if(s[0]=='C')
                        {
                                int x1,y1,x2,y2;
                                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                                update(x1,x2,y1,y2,1,n,1);
                        }
                        else
                        {
                                ans=0;
                                int x1,y1;
                                scanf("%d%d",&x1,&y1);
                                query(x1,y1,1,n,1);
                                printf("%d\n",ans);
                        }
                }
                printf("\n");
        }
}

   
   

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值