浙江中医药大学暑期训练测试赛八G

Problem G: Decreasing String

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 133   Solved: 51
[ Submit][ Status][ Web Board]

Description

You need to find a string which has exactly K positions in it such that the character at that position comes alphabetically later than the character immediately after it. If there are many such strings, print the one which has the shortest length. If there is still a tie, print the string which comes the lexicographically earliest (would occur earlier in a dictionary).

Input

The first line contains the number of test cases T. Each test case contains an integer K (≤ 100).

Output

Output T lines, one for each test case, containing the required string. Use only lower-case letters a-z.

Sample Input

2
1
2

Sample Output

ba
cba

AC代码:
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                int n;
                scanf("%d",&n);
                for(int i=n;i>=1;i--)
                {
                        int m=i%25;
                        if(m==0)
                                printf("z");
                        else if(m==1)
                                printf("ba");
                        else
                                printf("%c",m+'a');
                }
                printf("\n");
        }
        return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值