【忘了面试】转圈建立方阵,奇数偶数圈不同方向

package top.actim.test07;

/* 示例输入
**	1		几组数据
**	5 1		矩阵边长 查询次数
**	1 4		横坐标	纵坐标
*/

/* 示例输出
** 6		生成矩阵对应坐标下的值
*/
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = Integer.parseInt(sc.nextLine());

		while (n-- > 0) {
			String[] wit = sc.nextLine().split(" ");
			int N = Integer.parseInt(wit[0]);
			int M = Integer.parseInt(wit[1]);

			int[][] ans = new int[N][N];

			int len = N - 1;
			int count = 1;
			for (int i = 1; i <= N / 2 + 1; i++) {

				int a = i - 1; // hang
				int b = N - i; // lie
				int c = N - i; // hang
				int d = i - 1; // lie

				if (i % 2 == 1) {
					for (int j = 0; j < len; j++) {
						ans[a][a + j] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[a + j][b] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[c][b - j] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[c - j][d] = count++;
					}
				} else {
					for (int j = 0; j < len; j++) {
						ans[a + j][a] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[b][a + j] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[c - j][b] = count++;
					}
					for (int j = 0; j < len; j++) {
						ans[d][c - j] = count++;
					}
				}

				len -= 2;
			}

			if (N % 2 == 1) {
				ans[N / 2][N / 2] = N * N;
			}

			for (int i = 0; i < M; i++) {
				wit = sc.nextLine().split(" ");
				System.out.println(ans[Integer.parseInt(wit[0])][Integer.parseInt(wit[1])]);
			}

		}

	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值