ccf_201312-3_最大的矩形

在这里插入图片描述
在这里插入图片描述

样例输入
6
3 1 6 5 2 3
样例输出
10

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int n,max_s = 0;
    vector<int> rect;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        int t;
        cin>>t;
        rect.push_back(t);
    }
    for (int i = 0; i < n; ++i) {
        int w = 1,s = 0,h = rect[i];
        while (h){
            w = 1;
            for (int j = i + 1; j < n; ++j) {
                if(rect[j] < h) break;
                ++w;
            }
            s = w*h;
            if(max_s < s)
                max_s = s;
            --h;
        }
    }
    cout<<max_s;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值