Flip Game

题目:

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

 

题意:

有一个4*4的棋盘,上面布满黑白两面的棋子,有的黑色朝上,有的白色朝上;

问最少经过几次翻转操作(翻转每一个棋子时其上下左右的棋子也要翻转)能使棋盘颜色统一;

 

思路:

暴搜,遍历每一个位置翻或不翻,每一次都判断颜色是否统一;

 

代码:

#include<stdio.h>
int minn(int a,int b)
{
    return a<b?a:b;
}
char mp[20][20];
int dis[4][2]= {0,1,1,0,-1,0,0,-1},min1;
int judge()
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            if(mp[i][j]!=mp[0][0])
                return 0;
    return 1;
}
void op(int x,int y)
{
    if(mp[x][y]=='w')
        mp[x][y]='b';
    else mp[x][y]='w';
    for(int i=0; i<4; i++)
    {
        int tx=x+dis[i][0];
        int ty=y+dis[i][1];
        if(tx<0||ty<0||tx>=4||ty>=4)
            continue;
        if(mp[tx][ty]!='w')
            mp[tx][ty]='w';
        else mp[tx][ty]='b';
    }
}
void dfs(int x,int y,int step)
{
    if(step>min1)
        return ;
    if(judge())
    {
        min1=minn(min1,step);
        return ;
    }
    if(x==4)
        return ;
    op(x,y);
    if(y>=3)
        dfs(x+1,0,step+1);
    else dfs(x,y+1,step+1);
    op(x,y);
    if(y>=3)
        dfs(x+1,0,step);
    else dfs(x,y+1,step);
}
int main()
{
    for(int i=0; i<4; i++)
        scanf("%s",mp[i]);
    min1=999999;
    dfs(0,0,0);
    if(min1>16)
        printf("Impossible\n");
    else printf("%d\n",min1);
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
pygame.transform.flip() is a method in the Pygame library that is used to flip an image along its axis. This method can be used to create mirror images or to change the orientation of an image. The method takes three arguments: the image to be flipped, a boolean value indicating whether to flip the image horizontally, and a boolean value indicating whether to flip the image vertically. Syntax: ``` pygame.transform.flip(surface, xbool, ybool) ``` - surface: The image to be flipped. - xbool: A boolean value indicating whether to flip the image horizontally (True or False). - ybool: A boolean value indicating whether to flip the image vertically (True or False). Example: ``` import pygame pygame.init() # Set up the display display_width = 640 display_height = 480 game_display = pygame.display.set_mode((display_width, display_height)) # Load the image my_image = pygame.image.load("image.png") # Flip the image horizontally flipped_image = pygame.transform.flip(my_image, True, False) # Display the original and flipped images game_display.blit(my_image, (0, 0)) game_display.blit(flipped_image, (display_width/2, 0)) pygame.display.update() # Quit the game pygame.quit() ``` In the above example, we first load an image using the `pygame.image.load()` method. We then use the `pygame.transform.flip()` method to create a flipped version of the image by passing in `True` as the first argument to indicate that we want to flip the image horizontally. We then display both the original and flipped images using the `blit()` method. Finally, we update the display and quit the game.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值