Tree Recovery

题目:

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

 

题意:

给出二叉树的前序遍历和中序遍历,求出后序遍历;

 

思路:

1.前序遍历:根左右 2.中序遍历:左根右 3.后序遍历:左右根

真理1.前序遍历的第一个点是根节点。  

2.中序遍历的根节点左侧是树的左子树,根节点右侧是树的右子树。  

3.后序遍历的最后一个是根节点。

假设中序遍历中根节点的位置是a,那么后序遍历中0~a个点是树的左子树节点,a~n-2(数组从0开始)个点是树的右子树节点。

神奇的函数:strchr()是string.h中的函数,strchr(a,b)返回b元素在字符串a中第一次出现的地址c+a字符串的地址(就是c+a数组的地址)

 

代码:

#include<stdio.h>
#include<string.h>
void bulid(int n,char s1[],char s2[])
{
    if(n<=0)
        return;
    int t=strchr(s2,s1[0])-s2;
    bulid(t,s1+1,s2);//左子树
    bulid(n-t-1,s1+t+1,s2+t+1);//右子树
    printf("%c",s1[0]);
}
int main()
{
    char s1[10010],s2[10010];
    while(~scanf("%s%s",s1,s2))
    {
        int l=strlen(s1);
        bulid(l,s1,s2);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值