Trees on the level

题目:

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

 

题意:

输入一颗二叉树,你的任务是按照从上到下,从左到右的顺序输出各个结点的值。每个结点都按照从根结点到他的移动顺序给出(L表示左,R表示右)。在输入中,每个结点的左括号和右括号之间没有空格,相邻结点之间用一个空格隔开。每棵树的输入用一对空括号()结束。如果不能建成树输出 not complete;

 

思路:

建一棵树,然后把每个节点的路径保存到set容器中,保证路径不能相同,之后利用深搜,从字符串为空,每次添加L或R检查新的字符串是否存在,如果存在sum+1,如果最后sum == t(输入的节点数)则说明能构成树。

 

代码:

#include<stdio.h>
#include<set>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
int t,fff,sum;
set<string>h;
struct node
{
    int a,l;
    char ss[300];
} s[300];
bool cmp(node x,node y)
{
    if(x.l==y.l)return strcmp(x.ss,y.ss)<0;
    else return x.l<y.l;
}
void dfs(int a,string as)
{
    int i=a;
    while(i<t)
    {
        if(as.length()+1<strlen(s[i].ss))break;
        string ac=as+'L';
        if(ac.compare(s[i].ss)==0)
        {
            sum++;
            dfs(i+1,ac);
        }
        ac=as+'R';
        if(ac.compare(s[i].ss)==0)
        {
            sum++;
            dfs(i+1,ac);
            break;
        }
        i++;
    }
}
int main()
{
    char k[300];
    while(~scanf("%s",k))
    {
        h.clear();
        t=0;
        fff=0;
        int flag=0;
        int gen=-0x3f3f3f3f;
        if(strlen(k)==2)
        {
            printf("not complete\n");
            continue;
        }
        else do
            {
                int l=strlen(k);
                if(l==2)
                    break;
                int num=0;
                int i=1,f=0,bl=0;
                char b[300];
                for(int j=0; j<300; j++)b[j]='\0';
                while(k[i]<='9'&&k[i]>='0')
                {
                    num=num*10+k[i]-'0';
                    i++;
                }
                i++;
                while(k[i]=='L'||k[i]=='R')
                {
                    f=1;
                    b[bl++]=k[i];
                    i++;
                }
                if(f==0)
                {
                    if(flag==0)
                    {
                        gen=num;
                        flag=1;
                    }
                    else fff=1;
                }
                else
                {
                    if(h.find(b)!=h.end())
                        fff=1;
                    else
                    {
                        h.insert(b);
                        s[t].a=num;
                        strcpy(s[t].ss,b);
                        s[t++].l=strlen(b);
                    }
                }
            }
            while(scanf("%s",k));
        sort(s,s+t,cmp);
        if(gen==-0x3f3f3f3f)fff=1;
        if(fff==1)printf("not complete\n");
        else
        {
            sum=0;
            dfs(0,"");
            if(sum!=t)fff=1;
            if(fff==1)printf("not complete\n");
            else
            {
                printf("%d",gen);
                for(int i=0; i<t; i++)
                    printf(" %d",s[i].a);
                printf("\n");
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值