ZOJ 3471 Most Powerful(状压DP)

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


状压Dp,对每一个状态进行拓展。

二进制中1代表消失,0代表存在。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
//int sum[]={1,2,4,8,16,32,64,128,256,512,1024};
int dp[1100],n;
int mp[15][15];
int main()
{
   while(~scanf("%d",&n)&&n)
   {
       for(int i=0;i<n;i++)
       {
           for(int j=0;j<n;j++)
            scanf("%d",&mp[i][j]);
       }
       memset(dp,0,sizeof(dp));
       for(int i=0;i<(1<<n);i++)
       {
           for(int j=0;j<n;j++)
           {
               if(i&(1<<j))  continue;
               for(int k=0;k<n;k++)
               {
                   if(i&(1<<k)||j==k)  continue;
                   dp[i|(1<<j)]=max(dp[i|(1<<j)],dp[i]+mp[k][j]);
               }
           }
       }
       int maxn=0;
       for(int i=1;i<(1<<n)-1;i++)
          maxn=max(maxn,dp[i]);
       printf("%d\n",maxn);
   }
   return 0;
}


转载于:https://www.cnblogs.com/ljbguanli/p/7391051.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值