ZOJ 3471 Most Powerful(状压dp)


Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


题意: n中气体,a[i][j]表示 i 和j撞后 j消失得到的价值,求最大得到的价值为多少?


思路:状压dp,从后往前推状态



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef long long ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 11

ll dp[1<<11];
ll a[N][N];
int n;

void solve()
{
	int i,j,cur;
	ll ans=0;
	int len=1<<n;

	for(cur=len-1;cur>=0;cur--)  //枚举当前的状态
		fre(i,1,n+1)                     //有 i 气体
	   {
		  if(!(cur&(1<<(i-1)))) continue;

		  fre(j,1,n+1)                   //有 j 气体
		    {
                if(i==j) continue;
		    	if(!(cur&(1<<(j-1)))) continue;

		        int to=cur^(1<<(j-1));    //a[i][j] j 消失后状态

                dp[to]=max(dp[to],dp[cur]+a[i][j]);

                if(ans<dp[to])
				 ans=dp[to];

		    }

	   }

     pf("%lld\n",ans);

}

int main()
{
	int i,j;
	while(sf(n),n)
	{
		fre(i,1,n+1)
		 fre(j,1,n+1)
		 {
		 	scanf("%lld",&a[i][j]);
		 }

        mem(dp,0);

        solve();
	}
   return 0;
}







  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值