Winter-2-STL-F Ananagrams 解题报告及测试数据

Time Limit:3000MS     Memory Limit:0KB 
Description
Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.
Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.
Sample input
ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#
Sample output
Disk
NotE
derail
drIed
eye
ladder
soon

题解:

  1. 去掉输入过程中重复的单词,需要对统一小写后的单词排序,例如 aab cdf frf aab AaB,小写排序后是aab aab aab cad frf,那么很容易遍历一遍进行标记,将输入重复的单词只保留一个。

  2. ​ 寻找回文,例如adc cda utg 三个单词,对每一个单词进行字母排序后再整体排序,排序结果是:acd acd gtu ,出现次数大于一次的很显然是回文, 那么和上面一样,很容易遍历2遍后将出现次数大于一次的单词去掉。最后剩下的就是非回文。然后对非回文进行排序输出即可。               

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
using namespace std;
string ss[10000];
char s[100];
int k,k2,tag[10000];
struct Node{
    string ori,low,sor;//ori原始输入,low小写处理,sor字母排序
}str[10000];
bool cmp1(Node a,Node b){//按照小写后单词进行排序处理
    return a.low < b.low;
}
bool cmp2(Node a,Node b){//按照字母排序后的单词排序处理
    return a.sor < b.sor;
}
void set(Node&b,Node&a){//赋值操作
    b.ori =  a.ori;b.low = a.low;b.sor=a.sor;
}
int main(){
    //freopen("1.in","r",stdin);
    while(scanf("%s",s)!=EOF && s[0]!='#'){
        str[k].ori = s;
        for(int i=0;s[i];i++)s[i]=tolower(s[i]);
        str[k].low = s ;//小写
        sort(s,s+strlen(s));
        str[k++].sor = s;//排序
    }
        //对小写后的单词进行排序,目的是去除输入过程中重复的单词
    sort(str,str+k,cmp1);
    string pre = "";
    for(int i=0;i<k;i++){
        if(str[i].low == pre)tag[i]=1;
        pre = str[i].low;
    }
    for(int i=0;i<k;i++){
        if(!tag[i])set(str[k2++],str[i]);
        else tag[i]=0;
    }
        //对字母排序后的单词排序,目的是寻找回文单词
    k = k2;
    sort(str,str+k,cmp2);
    pre = "";
    for(int i=0;i<k;i++){
        if(str[i].sor == pre)tag[i]=1;
        pre = str[i].sor;
    }
    for(int i=0;i<k;i++)
        if(tag[i])tag[i-1]=1;
    k2=0;
    for(int i=0;i<k;i++)
        if(!tag[i])ss[k2++]=str[i].ori;
        //最后对原始输入排序输出。
    sort(ss,ss+k2);
    for(int i=0;i<k2;i++)
        cout << ss[i]<<endl;
}

  

 

转载于:https://www.cnblogs.com/gzdaijie/p/4298829.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值