Spring-1-F Dice(HDU 5012)解题报告及测试数据

Dice

Time Limit:1000MS     Memory Limit:65536KB

Description

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information) 

Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal. 

Input

There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A.

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.

Output

For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.

 

Sample Input

1 2 3 4 5 6

1 2 3 4 5 6

1 2 3 4 5 6

1 2 5 6 4 3

1 2 3 4 5 6

1 4 2 5 3 6

 

Sample Output

0

3

-1 

题解:

  1. 正确表示正方体,用a1-a6表示。注意a1-a6分别表示的是上下左右前后六个面,顺序不能换。 

  2. 使用map记录步数,以及查看该状态是否已经尝试过。

  3. 广度优先搜索,求得的结果即是最少的步数。

  4. ​注意翻转后的数组不要写错。       

以下是代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <sstream>
#include <queue>
#include <stack>
#include <stack>
#include <map>
using namespace std;
 
#define F(i,s,e) for(int i = s;i<e;i++)
#define ss(x) scanf("%d",&x)
#define write() freopen("1.in","r",stdin)
#define W(x) while(x)
 
string s1,s2;
string change(string str,int k){//1 l 2 r 3 f 4 b
    string s="";
    int a[6]={0,1,2,3,4,5};
    switch(k){//实现四种翻转
        case 1:a[0]=2;a[1]=3;a[2]=1;a[3]=0;break;
        case 2:a[0]=3;a[1]=2;a[2]=0;a[3]=1;break;
        case 3:a[0]=4;a[1]=5;a[4]=1;a[5]=0;break;
        case 4:a[0]=5;a[1]=4;a[4]=0;a[5]=1;break;
    }
    F(i,0,6)s+=str[a[i]];
    return s;
}
int bfs(){
    map<string ,int > ma;//记录步数
    queue<string>q;
    string t1,t2;
    ma[s1]=0;
    q.push(s1);
    W(!q.empty()){
        t1 = q.front();
        q.pop();
        if(t1 == s2)return ma[t1];
        F(i,1,5){
            t2 = change(t1,i);
            if(ma.find(t2)==ma.end()){//广度优先
                q.push(t2);
                ma[t2]=ma[t1]+1;
            }
        }
    }
    return -1;
}
 
int main(){
    //write();
    int t;
    W(ss(t)!=EOF){
        s1=s2="";
        s1+=t+'0';
        F(i,0,5){
            ss(t);
            s1+=t+'0';
        }
        F(i,0,6){
            ss(t);
            s2+=t+'0'; 
        }
        cout << bfs()<<endl;   
    }
}

  

 
 

转载于:https://www.cnblogs.com/gzdaijie/p/4311909.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值