HDOJ-2124之Repair the Wall

Repair the Wall

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon. 

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood. 

One day, Kitty found that there was a crack in the wall. The shape of the crack is a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors. The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap. 

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ? 

 

Input

The problem contains many test cases, please process to the end of file( EOF ). 
Each test case contains two lines. 
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which 
mentioned above. 
In the second line, there are N positive integers. The i th integer Ai(0<Ai<1000000000 ) means that the i th block has the size of 1×Ai (in inch). 

 

Output

For each test case , print an integer which represents the minimal number of blocks are needed. 
If Kitty could not repair the wall, just print "impossible" instead. 

 

Sample Input

5 3

3 2 1

 

5 2

2 1

 

Sample Output

2

impossible

 

这道题虽然题目很长,但读懂题意的话还是很简单的!贪心算法练手题!大致题意:用规格为1*Ai的矩形木块来补墙上的1*l的矩形(巨型)裂缝,因为要用到__int64!既然宽都一样,只需用一个一维数组记录木块的长度就行了。之后再对数组排序,从大到小依次相加记为sum,等到sum大于裂缝长度(即L),记录这之前所用的木块就行了。代码如下:

#include<iostream>
#include<algorithm>
using namespace std;//sort头文件
bool cmp(__int64 a,__int64 b){
    return a>b;
}
int main(){
	__int64 l,a[601];
	int n;
	while(~scanf("%I64d%d",&l,&n)){
		for(int i=0;i<n;i++)
			scanf("%I64d",&a[i]);
		sort(a,a+n,cmp);//使数组a从大到小排列
		__int64 sum=0;
		int ans=0,count=0;
		for(int i=0;i<n;i++){
			sum+=a[i];
			count++;//计数器
			if(sum>=l){
				ans=1;//小技巧:如果if语句没有执行,既是sum<l,裂缝没能补完
				break;
			}
		}
		if(ans)
		printf("%d\n",count);
		else
		printf("impossible\n");
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值