[hdu 4274]Spy's Work 树形dp

Spy's Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1266    Accepted Submission(s): 388


Problem Description
I'm a manager of a large trading company, called ACM, and responsible for the market research. Recently, another trading company, called ICPC, is set up suddenly. It's obvious that we are the competitor to each other now!
To get some information about ICPC, I have learned a lot about it. ICPC has N staffs now (numbered from 1 to N, and boss is 1), and anybody has at most one superior. To increase the efficiency of the whole company, the company contains N departments and the ith department is led by the ith staff. All subordinates of the ith staff are also belong to the ith department.
Last week, we hire a spy stealing into ICPC to get some information about salaries of staffs. Not getting the detail about each one, the spy only gets some information about some departments: the sum of the salaries of staff s working for the ith department is less than (more than or equal to) w. Although the some inaccurate information, we can also get some important intelligence from it.
Now I only concerned about whether the spy is telling a lie to us, that is to say, there will be some conflicts in the information. So I invite you, the talented programmer, to help me check the correction of the information. Pay attention, my dear friend, each staff of ICPC will always get a salary even if it just 1 dollar!
 

Input
There are multiple test cases.
The first line is an integer N. (1 <= N <= 10,000)
Each line i from 2 to N lines contains an integer x indicating the xth staff is the ith staff's superior(x<i).
The next line contains an integer M indicating the number of information from spy. (1 <= M <= 10,000)
The next M lines have the form like (x < (> or =) w), indicating the sum of the xth department is less than(more than or equal to) w (1 <= w <=100,000,000)
 

Output
For each test case, output "True" if the information has no confliction; otherwise output "Lie".
 

Sample Input
  
  
5 1 1 3 3 3 1 < 6 3 = 4 2 = 2 5 1 1 3 3 3 1 > 5 3 = 4 2 = 2
 

Sample Output
  
  
Lie True
 

Source
 


题目大意

一个公司是一个树状结构(每个人有一个直接上司,1号员工是主管)

现在已知m条信息,每条信息的格式是该员工及其下属所得薪资总合 大于 小于 或等于 某个值,问这些信息是否相互矛盾


解题思路

树状dp 每个节点记录最大值与最小值,dfs处理每个点,每个点的min更新为其下属的min之和 +1(至少有一元薪水)

并判断max是否<min即可

dp确实范围比较广了,还是要对图论的一些内容有些认识


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <ctime>
#include <cctype>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>

#define sqr(x) ((x)*(x))
#define LL long long 
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define eps 1e-10
#define maxn 10007
using namespace std;
int nex[maxn+5],u[maxn+5],v[maxn+5];
LL maxx[maxn+5],minn[maxn+5];
int en;
int fir[maxn+5];
int n,m,num,number,flag;
char relative;
void addedge(int x,int y)
{
  en++;
  u[en]=x;
  v[en]=y;
  nex[en]=fir[u[en]];
  fir[u[en]]=en;
}
void dfs(int x)
{
  LL mi=1;
  for (int e=fir[x];~e;e=nex[e])
  {
    dfs(v[e]);
    mi+=minn[v[e]];
  }
  minn[x]=max(mi,minn[x]);
  if (maxx[x]<minn[x])flag=1;
  // printf("x=%d ma=%lld mi=%lld\n",x,maxx[x],minn[x] );
}
int main()
{
  while (~scanf("%d",&n))
  {
    en=0;
    memset(fir,-1,sizeof fir);
    flag=0;
    for (int i=1;i<=n;i++)
    {
      minn[i]=1;
      maxx[i]=0x3f3f3f3f3f3f3f3fll;
    }
    for (int i=2;i<=n;i++)
    {
      scanf("%d",&m);
      addedge(m,i);
    }
    scanf("%d",&m);
    for (int i=1;i<=m;i++)
    {
      scanf("%d %c %d",&num,&relative,&number);
      if (relative=='<') maxx[num]=min(maxx[num],(LL)number-1);
      if (relative=='>') minn[num]=max(minn[num],(LL)number+1);
      if (relative=='=') {
        maxx[num]=min(maxx[num],(LL)number);
        minn[num]=max(minn[num],(LL)number);
      }
    }
    dfs(1);
    if (flag) puts("Lie");
    else puts("True");
  }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值