acdream 1146 Moist

本文介绍了一种用于计算卡片排序机器人所需费用的方法。该机器人通过插入排序的方式将收集的花样滑冰交易卡片按字母顺序排列,每移动一张卡片将产生一美元的费用。文章提供了一个算法实现案例,通过比较相邻卡片的顺序来确定是否需要移动卡片。
摘要由CSDN通过智能技术生成

Problem Description

Moist has a hobby -- collecting figure skating trading cards. His card collection has been growing, and it is now too large to keep in one disorganized pile. Moist needs to sort the cards in alphabetical order, so that he can find the cards that he wants on short notice whenever it is necessary.

The problem is -- Moist can't actually pick up the cards because they keep sliding out his hands, and the sweat causes permanent damage. Some of the cards are rather expensive, mind you. To facilitate the sorting, Moist has convinced Dr. Horrible to build him a sorting robot. However, in his rather horrible style, Dr. Horrible has decided to make the sorting robot charge Moist a fee of $1 whenever it has to move a trading card during the sorting process.

Moist has figured out that the robot's sorting mechanism is very primitive. It scans the deck of cards from top to bottom. Whenever it finds a card that is lexicographically smaller than the previous card, it moves that card to its correct place in the stack above. This operation costs $1, and the robot resumes scanning down towards the bottom of the deck, moving cards one by one until the entire deck is sorted in lexicographical order from top to bottom.

As wet luck would have it, Moist is almost broke, but keeping his trading cards in order is the only remaining joy in his miserable life. He needs to know how much it would cost him to use the robot to sort his deck of cards.

Input

The first line of the input gives the number of test cases, T(1 ≤ T ≤ 100).

T test cases follow.

Each one starts with a line containing a single integer, N(1 ≤ N ≤ 100).

The next N lines each contain the name of a figure skater, in order from the top of the deck to the bottom.

Each name will consist of only letters and the space character.
Each name will contain at most 100 characters.
No name with start or end with a space.
No name will appear more than once in the same test case.

Output
For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) and y is the number of dollars it would cost Moist to use the robot to sort his deck of trading cards.
Sample Input
3
2
Oksana Baiul
Michelle Kwan
3
Elvis Stojko
Evgeni Plushenko
Kristi Yamaguchi
4
Evgeni Plushenko
Kristi Yamaguchi
Elvis Stojko
Aksana Baiul
Sample Output
Case #1: 1
Case #2: 0
Case #3: 2

类似插入排序,统计插入的次数。

/*
* this code is made by yuexunjiang
* Problem: 1146
* Verdict: Accepted
* Submission Date: 2015-07-07 13:37:24
* Time: 4MS
* Memory: 1692KB
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
const int MAXN = 100 + 5;
 
char ch[MAXN][MAXN];
vector<char*> v;
 
int main(){
#if 0
    freopen("A.in","rt",stdin);
#endif
    int t,n,num = 1;
    cin >>t;
    while(t--){
        cin >>n;
        getchar();
        v.clear();
        for(int i = 0;i < n;i++){
            fgets(ch[i],MAXN,stdin);
            v.push_back(ch[i]);
        }
        int cnt = 0;
        for(vector<char *>::iterator it=v.begin()+1; it!=v.end(); ++it){
            if(strcmp(*it, *(it-1)) < 0){
                v.erase(it);
                --it;
                cnt++;
            }
        }
        cout <<"Case #" <<num++ <<": "<<cnt <<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值