poj1700 Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

注意分情况讨论。

 

尤其是有两种方法:(事先排序,由快到慢)

第一:      第一次: 快的 和次快的   快的回来  a[0]+a[1]

              第二次: 最慢的和倒数第二慢的去   次快的回来   a[n-1]+a[1]

             第三次:  快的和次快的去     a[1]

           

第二: 一直是快的去带着最慢到次慢。

            第一次: 最快的和最慢的  最快的回来   a[n-1]+a[0]

           第二次:最快的和倒数第二慢的  还是快的回来   a[n-2]+a[0]

           第三次:最快的和次快的回来 a[1]

 

要强调的是,由于可能是多个,所以判断是将两种方式的总和进行比较,但是到了加的时候,只需要加前两次的,然后再最后-2,因为是快的和次快的将两人最慢的人运到了对面。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1010];
int main(){
	int t;
	scanf("%d",&t); 
	while(t--){
		int n;
		int sum=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		sort(a,a+n);
		while(1){
			if(n==1){
				sum+=a[0];
				break;
			}
			if(n==2){
				int x=max(a[0],a[1]);
				sum+=x;
				break;
			}
			if(n==3){
				sum+=(a[0]+a[1]+a[2]);
				break;
			}if(n>=4){
				int s1=2*a[0]+a[1]+a[n-1]+a[n-2];
				int s2=a[0]+3*a[1]+a[n-1];
				if(s1<=s2){
					sum+=(2*a[0]+a[n-2]+a[n-1]);
				}else{
					sum+=(a[0]+2*a[1]+a[n-1]);
				}
				n=n-2;
			}
		}
		printf("%d\n",sum);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值