1055. The World's Richest (25)

Forbes magazinepublishes every year its list of billionaires based on the annual ranking ofthe world's wealthiest people. Now you are supposed to simulate this job, butconcentrate only on the people in a certain range of ages. That is, given thenet worths of N people, you must find the M richest people in a given range oftheir ages.

Input Specification:

Each input filecontains one test case. For each case, the first line contains 2 positiveintegers: N (<=105) - the total number of people, and K (<=103)- the number of queries. Then N lines follow, each contains the name (string ofno more than 8 characters without space), age (integer in (0, 200]), and thenet worth (integer in [-106, 106]) of a person. Finallythere are K lines of queries, each contains three positive integers: M (<=100) - the maximum number of outputs, and [Amin, Amax] which are the range ofages. All the numbers in a line are separated by a space.

OutputSpecification:

For each query,first print in a line "Case #X:" where X is the query number startingfrom 1. Then output the M richest people with their ages in the range [Amin, Amax].Each person's information occupies a line, in the format

Name AgeNet_Worth

The outputs must bein non-increasing order of the net worths. In case there are equal worths, itmust be in non-decreasing order of the ages. If both worths and ages are thesame, then the output must be in non-decreasing alphabetical order of thenames. It is guaranteed that there is no two persons share all the same of thethree pieces of information. In case no one is found, output "None".

Sample Input:

12 4

Zoe_Bill 35 2333

Bob_Volk 24 5888

Anny_Cin 95999999

Williams 30 -22

Cindy 76 76000

Alice 18 88888

Joe_Mike 32 3222

Michael 5 300000

Rosemary 40 5888

Dobby 24 5888

Billy 24 5888

Nobody 5 0

4 15 45

4 30 35

4 5 95

1 45 50

Sample Output:

Case #1:

Alice 18 88888

Billy 24 5888

Bob_Volk 24 5888

Dobby 24 5888

Case #2:

Joe_Mike 32 3222

Zoe_Bill 35 2333

Williams 30 -22

Case #3:

Anny_Cin 95999999

Michael 5 300000

Alice 18 88888

Cindy 76 76000

Case #4:

None

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#define N 500000
#define M 1000
using namespace std;
int same[N];
struct E{
   string name;
   int age;
   int mon;
}num[N],tmp[N];
int com[M][3];
bool cmp(E a,E b)
{
     if(a.mon!=b.mon) 
         return a.mon>b.mon;
     if(a.age!=b.age) 
        return a.age<b.age;
     if(a.mon==b.mon && a.age==b.age) return a.name<b.name;    
}
int main()
{
    int n,k,i,j,f,p,len,t;
    string nam;
    int ag,mo;
    freopen("1055_r.txt","r",stdin);
    freopen("1055_w.txt","w",stdout);
    while(scanf("%d%d",&n,&k)!=EOF){
         len=-1;
         memset(same,0,sizeof(same));
         for(i=0;i<n;i++){
             cin>>num[i].name>>num[i].age>>num[i].mon;
             same[num[i].age]++;
             if(same[num[i].age]<100){
                 t=(++len);
                 tmp[t].name=num[i].name;
                 tmp[t].age=num[i].age;
                 tmp[t].mon=num[i].mon;
             }
         }
         len++;
         for(j=0;j<k;j++){
             scanf("%d%d%d",&com[j][0],&com[j][1],&com[j][2]);
         }
         sort(tmp,tmp+len,cmp);
         for(i=0;i<k;i++){
             p=com[i][0];
             f=1;
             printf("Case #%d:\n",i+1);
             for(j=0;j<len;j++){
                 if(tmp[j].age>=com[i][1]&& tmp[j].age<=com[i][2] ){
                    printf("%s %d %d\n",tmp[j].name.c_str(),tmp[j].age,tmp[j].mon);
                    p--;
                    f=0;
                    if(p==0) break;
                 }            
             }   
             if(f) printf("None\n");             
         }
    }
    
    return 0;    
}

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值