两个数的平方和

给出一个整数N,将N表示为2个整数i j的平方和(i <= j),如果有多种表示,按照i的递增序输出。
例如:N = 130,130 = 3^2 + 11^2 = 7^2 + 9^2 (注:3 11同11 3算1种)
Input一个数N(1 <= N <= 10^9) Output共K行:每行2个数,i j,表示N = i^2 + j^2(0 <= i <= j)。 
如果无法分解为2个数的平方和,则输出No Solution Sample Input
130
Sample Output
3 11
7 9


代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

int a[100001];
int l;

int cmp(int x)
{
    for(int i=0;i<l;i++)
    {
        if(x==a[i])
        {
            return false;
        }
    }
    return true;
}
int main()
{
    memset(a,0,sizeof(a));
    int n;
    scanf("%d",&n);
    int x,y;
    l=0;
    int m = (int)sqrt((double)n);
    int flag=1;
    for(int i=0;i<=m;i++)
    {
        x = i;
        y = (int)sqrt((double)(n-x*x));
        if(x*x+y*y==n)
        {
            a[l] = y;
            bool k =cmp(x);
            l++;
            if(k)
            {
                printf("%d %d\n",x,y);
                flag =0;
            }else{
              break;
            }
        }
    }
    if(flag==1) printf("No Solution\n");
    return 0;
}

转载于:https://www.cnblogs.com/new-zjw/p/8540947.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值