Add More Zero

There is a youngster known for amateur propositions concerning several mathematical hard problems. 

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between  00 and  (2m1)(2m−1) (inclusive). 

As a young man born with ten fingers, he loves the powers of  1010 so much, which results in his eccentricity that he always ranges integers he would like to use from  11 to  10k10k (inclusive). 

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could. 

Given the positive integer  mm, your task is to determine maximum possible integer  kkthat is suitable for the specific supercomputer.
InputThe input contains multiple test cases. Each test case in one line contains only one positive integer  mm, satisfying  1m1051≤m≤105. OutputFor each test case, output "  Case #xxyy" in one line (without quotes), where  xxindicates the case number starting from  11 and  yy denotes the answer of corresponding case. Sample Input
1
64
Sample Output
Case #1: 0
Case #2: 19

题意:
   (1)0 and (2m1)(inclusive).  

  (2)As a young man born with ten fingers, he loves the powers of 10 so much, which results in his   eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive). 

  简单的说就是,在0到(2^m-1)之间,求最大的10^k,求k的值。(英语好重要啊,想哭,真的!)

思路如下:

   10^k<=2^m-1 ==> 10^k<2^m ==> k<m*log10(2)


代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <math.h>

using namespace std;


int main()
{
    double mi = log10(2);
    int n,num=1;
    while(scanf("%d",&n)!=EOF)
    {
        double ans = n*mi;
        printf("Case #%d: %lld\n",num++,(long long)ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/new-zjw/p/8540937.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值