HDU 6033 Add More Zero 【数学】【基础】

Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 547    Accepted Submission(s): 390


Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between   0  and   (2m1)  (inclusive).

As a young man born with ten fingers, he loves the powers of   10  so much, which results in his eccentricity that he always ranges integers he would like to use from   1  to   10k  (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer   m , your task is to determine maximum possible integer   k  that is suitable for the specific supercomputer.
 

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer   m , satisfying   1m105 .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where   x  indicates the case number starting from   1  and   y  denotes the answer of corresponding case.
 

Sample Input
  
  
1 64
 

Sample Output
  
  
Case #1: 0 Case #2: 19
 

Source
 

Recommend
liuyiding

题目链接:

题目大意:

用10^k表示出2^m-1,求k的整数部分

解题思路:

因为1≤m≤1e5,所以2^m的最后一位只能为2,4,8,6,因此2^m-1中的-1对它的结果不会造成影响。

令10^k = 2^m 两边取对数,得 k = m*log10(2)的整数部分。

Mycode:

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX = 10005;
const int MOD = 1e9+7;
const int INF = 0x3f3f3f3f;

int main()
{
    int m, cas = 0;
    while(~scanf("%d",&m))
    {
        int ans = floor(m*log10(2));
        printf("Case #%d: %d\n",++cas, ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值